Bug 1654138 - Optimize for virt store fails with distribute volume type
Summary: Optimize for virt store fails with distribute volume type
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1638674 1653613
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 06:44 UTC by Krutika Dhananjay
Modified: 2019-06-18 10:39 UTC (History)
11 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1653613
Environment:
Last Closed: 2019-03-25 16:32:14 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21735 None Merged extras: Add group-distributed-virt for single-brick ovirt-gluster use-case 2018-12-05 04:00:51 UTC

Description Krutika Dhananjay 2018-11-28 06:44:08 UTC
+++ This bug was initially created as a clone of Bug #1653613 +++

Description of problem:
-----------------------
Fails to set group virt option on distribute volume type since some of the options are specific to replica volume types.

Version-Release number of selected component (if applicable):
--------------------------------------------------------------


How reproducible:
------------------
Always

Steps to Reproduce:
--------------------
1. Create a distribute volume and select optimize for virt store

Actual result:
--------------
Fails to set all volume options on the distribute volume

Expected result:
----------------
Create a separate virt profile with volume options applicable for distributed volume

--- Additional comment from Atin Mukherjee on 2018-11-27 09:30:53 EST ---

Krutika - I'm assigning this to you. Seems straight forward.

--- Additional comment from Krutika Dhananjay on 2018-11-27 22:10:32 EST ---

(In reply to Atin Mukherjee from comment #1)
> Krutika - I'm assigning this to you. Seems straight forward.

Indeed it is! But even before that, do you mind responding to https://bugzilla.redhat.com/show_bug.cgi?id=1638674#c6 ?

-Krutika

--- Additional comment from Atin Mukherjee on 2018-11-28 01:35:29 EST ---

Response has been captured at the RHHI BZ.

Comment 1 Worker Ant 2018-11-28 07:51:12 UTC
REVIEW: https://review.gluster.org/21735 (extras: Add group-distributed-virt for single-brick ovirt-gluster use-case) posted (#1) for review on master by Krutika Dhananjay

Comment 2 Worker Ant 2018-12-05 04:00:47 UTC
REVIEW: https://review.gluster.org/21735 (extras: Add group-distributed-virt for single-brick ovirt-gluster use-case) posted (#3) for review on master by Amar Tumballi

Comment 3 Shyamsundar 2019-03-25 16:32:14 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.