Bug 1654147 - [downstream clone - 4.2.8] [upgrade] Post upgrade, new options are not available in virt profile
Summary: [downstream clone - 4.2.8] [upgrade] Post upgrade, new options are not availa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.2.8
: ---
Assignee: Yuval Turgeman
QA Contact: Huijuan Zhao
Rolfe Dlugy-Hegwer
URL:
Whiteboard:
Depends On: 1643733
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 06:57 UTC by RHV bug bot
Modified: 2019-04-28 10:49 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Since /var is not layered, any new files that exist both on the new image and the running system are not copied from the image. Consequence: Packages that ship files under /var are not updated correctly. Fix: If an updated file exists on both the new image and the running system, the original file will be saved as ".imgbak" and the new file will be copied over. Result: Both original and new files exist under /var.
Clone Of: 1643733
Environment:
Last Closed: 2019-01-22 12:44:15 UTC
oVirt Team: Node
Target Upstream Version:
huzhao: testing_plan_complete+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0116 None None None 2019-01-22 12:44:20 UTC
oVirt gerrit 95207 master ABANDONED osupdater: copy over new files when migrating /var 2018-11-28 06:57:46 UTC
oVirt gerrit 95611 master MERGED Sync existing files in /var 2018-11-28 06:57:46 UTC
oVirt gerrit 95779 ovirt-4.2 MERGED Sync existing files in /var 2018-11-28 06:57:46 UTC

Description RHV bug bot 2018-11-28 06:57:29 UTC
+++ This bug is an upstream to downstream clone. The original bug is: +++
+++   bug 1643733 +++
======================================================================

Description of problem:
-----------------------
After upgrading from RHV 4.1.11, the new virt options are not available in virt profile ( /var/lib/glusterd/groups/virt )

Version-Release number of selected component (if applicable):
--------------------------------------------------------------
RHVH 4.1.11
RHVH 4.2.7

How reproducible:
------------------
6/6

Steps to Reproduce:
-------------------
1. Install RHVH 4.1.11
2. Check for the contents of virt profile 
3. Update to the latest RHVH 4.2.7
4. Check for the contents of virt profile

Actual results:
---------------
New virt profile still points to the old content


Expected results:
------------------
New virt profile should have the new content
Additional info:

(Originally by Satheesaran Sundaramoorthi)

Comment 1 RHV bug bot 2018-11-28 06:57:35 UTC
QE can reproduce this issue.

Test version:
# imgbase layout
rhvh-4.1-0.20180425.0
 +- rhvh-4.1-0.20180425.0+1
rhvh-4.2.7.3-0.20181026.0
 +- rhvh-4.2.7.3-0.20181026.0+1

Test steps:
1. Install redhat-virtualization-host-4.1-20180426.0
2. Check for the contents of virt profile /var/lib/glusterd/groups/virt
3. Upgrade rhvh to 4.2.7 rhvh-4.2.7.3-0.20181026.0
4. Check for the contents of virt profile /var/lib/glusterd/groups/virt
5. Clean install rhvh-4.2.7.3-0.20181026.0
6. Check for the contents of virt profile /var/lib/glusterd/groups/virt


Test results:
1. After step 4, the contents of virt profile is same as step 2:
# cat /var/lib/glusterd/groups/virt
performance.quick-read=off
performance.read-ahead=off
performance.io-cache=off
performance.low-prio-threads=32
network.remote-dio=enable
cluster.eager-lock=enable
cluster.quorum-type=auto
cluster.server-quorum-type=server
cluster.data-self-heal-algorithm=full
cluster.locking-scheme=granular
cluster.shd-max-threads=8
cluster.shd-wait-qlength=10000
features.shard=on
user.cifs=off

2. After step 6, the contents of virt profile is not same as step 4:
# cat /var/lib/glusterd/groups/virt
performance.quick-read=off
performance.read-ahead=off
performance.io-cache=off
performance.low-prio-threads=32
network.remote-dio=enable
cluster.eager-lock=enable
cluster.quorum-type=auto
cluster.server-quorum-type=server
cluster.data-self-heal-algorithm=full
cluster.locking-scheme=granular
cluster.shd-max-threads=8
cluster.shd-wait-qlength=10000
features.shard=on
user.cifs=off
cluster.choose-local=off
client.event-threads=4
server.event-threads=4
performance.client-io-threads=on

(Originally by Huijuan Zhao)

Comment 3 Huijuan Zhao 2018-11-29 08:50:12 UTC
This bug is fixed in redhat-virtualization-host-4.2-20181128.0

Test version:
# imgbase layout
rhvh-4.1-0.20180425.0
 +- rhvh-4.1-0.20180425.0+1
rhvh-4.2.8.0-0.20181127.0
 +- rhvh-4.2.8.0-0.20181127.0+1

Test steps:
Same as comment 1

Test results:
1. After step4, the contents of virt profile is different as step 2
2. After step6, the contents of virt profile is same as step 4
So new virt profile has the new content.


So this bug is fixed in rhvh-4.2.8.0-0.20181127.0, will verify this bug once the status move to ON_QA.

Comment 4 Sandro Bonazzola 2018-12-03 09:01:56 UTC
4.3 is handled in https://bugzilla.redhat.com/show_bug.cgi?id=1643733

Comment 5 Huijuan Zhao 2018-12-04 01:59:08 UTC
According to comment 3, move to VERIFIED.

Comment 7 errata-xmlrpc 2019-01-22 12:44:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0116


Note You need to log in before you can comment on or make changes to this bug.