Bug 1654338 - tendrl-commons doesn't specify minimal ansible version it requires
Summary: tendrl-commons doesn't specify minimal ansible version it requires
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat Storage
Component: web-admin-tendrl-commons
Version: rhgs-3.4
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
: RHGS 3.4.z Batch Update 3
Assignee: gowtham
QA Contact: Filip Balák
Depends On:
TreeView+ depends on / blocked
Reported: 2018-11-28 14:53 UTC by Martin Bukatovic
Modified: 2022-07-09 10:20 UTC (History)
7 users (show)

Fixed In Version: tendrl-commons-1.6.3-15.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2019-02-04 07:43:46 UTC

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Github Tendrl commons issues 1054 0 None closed tendrl-commons package should depend on specific minimal version of ansible 2020-02-10 10:19:51 UTC
Red Hat Bugzilla 1648835 1 None None None 2023-09-15 00:13:51 UTC
Red Hat Product Errata RHSA-2019:0265 0 None None None 2019-02-04 07:44:07 UTC

Internal Links: 1648835

Description Martin Bukatovic 2018-11-28 14:53:01 UTC
Description of problem

Package tendrl-commons doesn't specify minimal ansible version it requires.
The problem is that RHGSWA may not work (eg. import can fail) when too
old ansible package is installed.

Version-Release number of selected component


Steps to Reproduce

1. enable RHGSWA repositories and install tendrl-commons
2. rpm -q tendrl-commons

Actual results

[root@usm1-server ~]# rpm -qR tendrl-commons | grep ansible

Expected results

[root@usm1-server ~]# rpm -qR tendrl-commons | grep ansible
ansible >= 2.y

where y is particular number, which identifies minimal ansible
version for RHGSWA to work.

Additional info

It's not clear which version should be specified as minimal version, since
RHGSWA supports ansible from rhel-7-server-ansible-2-rpms channel, which
provides latest 2.x ansible (ansible 2.7.2 right now).

Example of problem with using older ansible: BZ 1575485

Comment 1 Martin Bukatovic 2018-11-28 15:03:47 UTC
Testing approach

QE will test that particular minimal version works during
verification of this BZ, but all the other testing continue with latest ansible
build from rhel-7-server-ansible-2-rpms

There is no reason to test with the minimal version later, when such minimal
version is not supported (or expected to be used) anyway.

The reason to have minimal verions of ansible requirement in the package is to
notify admin that something is wrong when he forgets to subscribe to the ansible

Comment 2 Martin Bukatovic 2018-11-28 15:11:05 UTC
What is a minimal version we should specify here?

Comment 3 gowtham 2018-12-04 11:40:19 UTC
PR is under review: https://github.com/Tendrl/commons/pull/1068

Comment 4 gowtham 2018-12-05 03:00:36 UTC
Daniel PR is under review: https://github.com/Tendrl/commons/pull/1055

Comment 6 Martin Bukatovic 2018-12-12 18:19:14 UTC
Providing QA ack (see comment 1 for assumptions and planned testing approach).

Comment 10 Filip Balák 2019-01-18 13:14:20 UTC
# rpm -qa tendrl-commons 
# rpm -qR tendrl-commons | grep ansible

There is no minimal version specified. --> ASSIGNED

Comment 14 Filip Balák 2019-01-22 08:59:15 UTC
$ rpm -qa tendrl-commons
$ rpm -qR tendrl-commons | grep ansible
ansible >= 2.5

Looks ok. --> VERIFIED

Comment 16 errata-xmlrpc 2019-02-04 07:43:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.