Bug 165510 - First time K-Menu opens to wrong side
Summary: First time K-Menu opens to wrong side
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-09 22:34 UTC by Russell East
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-10 09:56:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Russell East 2005-08-09 22:34:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Sometime ago I was following the above KDE bug and attached a screenshot of the problem.  Later on, the KDE folks decided to mark it as a duplicate of their bug 89890 (https://bugs.kde.org/show_bug.cgi?id=89890) and according to the developer it has been fixed provided the correct version of QT has been provided.  According to the bug report, a patch was added to QT to make the fix.

Since upgrading to Fedora Core 4 last weekend, I hoped to see the problem fixed, but sadly, it is not fixed.  I'm wondering if the Fedora folks needed to incorporate the patch outlined the 89890 report??

Version-Release number of selected component (if applicable):
kdebase-3.4.2-0.fc4.1

How reproducible:
Always

Steps to Reproduce:
1.select KDE as default desktop
2.login, drag the KDE panel to the right of screen then logout
3.login once more, then click on the K applications menu.

The menu will appear (incorrectly) on screen left instead of screen right.
  

Actual Results:  see above

Expected Results:  see above

Additional info:

This is really irritating, particularly when I want to give a demo.  It makes Linux, KDE and everything look a little bit cheap.

Comment 1 Ngo Than 2005-08-10 09:56:18 UTC
it's now fixed in the new qt-3.3.4-15.2. I will add this new package in FC4
update soon. Thanks for your report.

Comment 2 Russell East 2005-09-15 16:43:54 UTC
Sorry to nag, but I haven't see this fix in the updates - it's been a month.  :-)

Comment 3 Ngo Than 2005-09-16 08:12:46 UTC
it's already built for FC4 update and still in the queue! I hope it will be
pushed out today. i'm sorry for delay

Comment 4 Fedora Update System 2005-09-16 15:55:05 UTC
From User-Agent: XML-RPC

qt-3.3.4-15.4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Comment 5 Russell East 2005-09-16 21:31:09 UTC
It works for me - actually I tried all 4 possible panel locations, and just
fine.  Thanks for fixing this!


Note You need to log in before you can comment on or make changes to this bug.