Bug 89890 - ddcprobe does not probe my laptop correctly
ddcprobe does not probe my laptop correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-29 10:38 EDT by Don Hardaway
Modified: 2014-03-16 22:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-08 08:34:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Does this code help (4.65 KB, text/plain)
2003-05-01 13:18 EDT, Don Hardaway
no flags Details

  None (edit)
Description Don Hardaway 2003-04-29 10:38:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
ddcprobe does not detect my laptop screen parameters.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run kudzu or anaconda or XFree86 probe
2.check out put from ddcprobe
3.
    

Actual Results:  does not identify screen information properly

Expected Results:  It would identify screen information so XFree86 could
configure properly.

Additional info:
Comment 1 Michael Fulbright 2003-04-29 12:12:44 EDT
ddcprobe does not work with laptop displays. You will need to manually specify
the monitor type.

Kudzu will need to probe LCDs someday.
Comment 2 Don Hardaway 2003-05-01 13:18:02 EDT
Created attachment 91448 [details]
Does this code help
Comment 3 Bill Nottingham 2003-05-01 14:11:09 EDT
Not exactly in this context, no. The DDC probe is currently graphics-card
agnostic, and that code is ATI specific.
Comment 4 Don Hardaway 2003-05-01 14:45:12 EDT
Cant this code be incorporated to at least get rid of some of the problems with
laptops with the ATI card?
Comment 5 Bill Nottingham 2003-05-01 14:49:36 EDT
Not generally, no.
Comment 6 Don Hardaway 2003-05-01 16:40:09 EDT
OK, I give. If a business person wanted to adopt rh9 to put on the employees
10,000 laptops what would the solution to the problem be?
Comment 7 Bill Nottingham 2003-05-01 17:06:06 EDT
Backing up, when you mean 'problems with laptops with the ATI card', do you mean
stability or display issues? That would be an X driver bug, and not relevant to
the DDC issue that was opened here.

As for configuring X in the abscence of DDC info, you can always
pass info in via kickstart, or change it with redhat-config-xfree86.
Comment 8 Don Hardaway 2003-05-01 19:34:21 EDT
both--randomly-when logging out or switching to the console using alt-cntl-f1,
the screen will just fade to a complete white screen and the whole machine is
frozen.   Also you can not change the colors from 16 bit to 24 bit or the screen
screws up and is unreadable. Now, since the ddcprobe can not provide the proper
parameters from the beginning and the user does not know them--XFree86 config
file is not entirely correct.  Some how windows does it correctly and rh
software whether it be X or ddcprobe or r128 driver or gnome--i don't know and I
can assure you the marketplace does not care.  All I know is when you recommend
rh9 to a bunch of business people that have thousands of Dell laptops since Dell
is king in the business world--rh9 better load and configure correctly or else
bill gates wins. I am sure we both would not want that to continue.  Someone
needs to take some leadership here and crush this little problem.
Comment 9 Bill Nottingham 2003-05-01 22:35:33 EDT
For the display issues, those are XFree86 bugs, and should be reported separately.
Comment 10 Mike A. Harris 2003-05-02 03:18:48 EDT
>OK, I give. If a business person wanted to adopt rh9 to put on the employees
>10,000 laptops what would the solution to the problem be?

I suppose one would call the laptop manufacturer or ATI on the phone and ask
them if their hardware is supported officially in Linux, and if not, when they
plan on producing open source support for their laptop hardware so that open
source vendors such as Red Hat and others can ship an OS that supports their
particular laptop(s).

Another possible solution would be if Red Hat were to acquire a company such
as ATI, and then switch the focus of hardware support to Linux, and open source
it for the greater benefit of the community.

There are likely other solutions also though, these are just two possibilities.

I kindof like the second idea.
Comment 11 Don Hardaway 2003-05-02 07:00:29 EDT
I am afraid that option 3 is what they are going to do given these types of
responses: Buy Microsoft.
Comment 12 Don Hardaway 2003-05-18 12:09:30 EDT
The ddc program is kudzu's responsibility is my understanding and it does not
get the proper results for the monitor when it probes for sync values (as in bug
75351).  If this is inaccurate please advise who to report this to.
Comment 13 Don Hardaway 2003-05-18 12:16:30 EDT
I would be happy to try betas of the program to see if they work on my laptop if
that would help.

Note You need to log in before you can comment on or make changes to this bug.