Bug 165528 - bogus module_verify_elf check rejects valid .ko files
bogus module_verify_elf check rejects valid .ko files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Howells
Brian Brock
:
: 166828 (view as bug list)
Depends On:
Blocks: 165416
  Show dependency treegraph
 
Reported: 2005-08-10 03:55 EDT by Roland McGrath
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 17:13:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix for bogus elf layout assertion in module verification (538 bytes, patch)
2005-08-10 03:55 EDT, Roland McGrath
no flags Details | Diff

  None (edit)
Description Roland McGrath 2005-08-10 03:55:25 EDT
Description of problem:

A bug in one of the sanity checks on kernel module files done by the module
signature checking stuff causes it to reject valid .ko files that happen to have
their section headers at the end of the file.  It's pure luck that older tools
haven't produced files with this layout before, and it could bite on future
builds after binutils/elfutils updates.  This bug should be cloned to all the FC
and RHEL release streams that have the module signing code.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Fix attached.
Comment 1 Roland McGrath 2005-08-10 03:55:37 EDT
Created attachment 117597 [details]
fix for bogus elf layout assertion in module verification
Comment 2 Frank Ch. Eigler 2005-08-11 13:08:21 EDT
Would a workaround in elfutils (or whoever is creating these newfangled files)
be prudent in the mean time, to avoid triggering the bug?
Comment 3 Roland McGrath 2005-08-15 17:13:59 EDT
Dave put the fix in.
Comment 4 Dave Jones 2005-08-31 19:12:27 EDT
*** Bug 166828 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.