Bug 166828 - can't produce a workable rebuilt kernel module
can't produce a workable rebuilt kernel module
Status: CLOSED DUPLICATE of bug 165528
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-26 05:31 EDT by Emmanuel Druon
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 19:12:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Druon 2005-08-26 05:31:33 EDT
Description of problem:
For some hardware specific problem, I need to create a new kernel package and
for some reason, I can't make a rebuilt kernel package to work (even if I don't
change a thing and just try to rebuild it)

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1398_FC4.src.rpm

How reproducible:
every time

Steps to Reproduce:
1. install kernel.***.src.rpm package
2. try to rebuild the kernel package (rpmbuild -bb -target=i686
/usr/src/redhat/SPECS/kernel-2.6.spec
3. install the new kernel (rpm -i kernel-2.6.12-1.1398_FC4.root.i686.rpm
4. boot the new kernel
5. most modules are not loaded and the following messages can be found in
/var/log/messages (for example) : 
...
modprobe: FATAL: Error inserting lp
(/lib/modules/2.6.12-1.1398_FC4.root/kernel/drivers/parport/parport.ko):
Accessing a corrupted libraty
kernel: Verify ELF error (assertion 110)
... 
  
Actual results:
see above

Expected results:
should load modules as done in the original kernel package version

Additional info:
my FC4 version is up to date with the latest package available
Comment 1 Emmanuel Druon 2005-08-26 11:55:41 EDT
ok, I've got new information concerning my bug report. I've re-installed a brand
new FC4 and only updated the kernel. Then applied the previous procedure again.
And things work.

Therefore, the bug must be triggered by one of the upgrade rpms (gcc or glibc
maybe). Thanks to Matthias Hensler this idea.

I'll try to investigate further on that path and keep you posted !
Comment 2 Dave Jones 2005-08-26 19:51:52 EDT

*** This bug has been marked as a duplicate of 126342 ***
Comment 3 Emmanuel Druon 2005-08-27 16:34:21 EDT
I don't agree with this bug being marked as a duplicate of 126342 since in the
procedure I describe, I don't even temper with the kernel. Taking the src rpm
and trying to rebuild it breaks things completly...
I hope you'll take that into account and reopen this bug...
Comment 4 Rik van Riel 2005-08-27 16:38:21 EDT
Emmanuel, did you install the kernel-devel package ?
Comment 5 Emmanuel Druon 2005-08-29 03:01:10 EDT
Riel, yes indeed.
Here are the latest information after some trials this week end. I hope that it
will convince you that this bug needs to be taken care of.
I re-installed a new FC4 version with ALL the packages (I know one should not do
that but I wanted to be sure that there was no hidden dependencies around. Then
I tried to rebuild my new kernel packages using the procedure stated in my first
post (just modifying the spec file so that rpmbuild doesn't rebuild the smp and
xen packages). I finished up with a working kernel.
Then I upgraded gcc, rebuilt a new kernel, still worked.
Upgraded libc, rebuilt the kernel, still worked.
Since I had installed everything and didn't have much time, I updagraded ALL the
other packages, rebuilt the kernel and this last one didn't work properly. I
finished up with the same error messages as before and was unable to load most
of the modules.
There seems to be a pb with on of the update package and I'll try to redo some
work with a lighter installation but I'd appreciate some help from you guys at
the FC team to help me pinpointing which package might produce this result.
Comment 6 Emmanuel Druon 2005-08-31 08:21:45 EDT
Found it !
The guilty package is the update of redhat-rpm-config.
If you downgrade to the redhat-rpm-config included in the distribution you can
repackage you kernel !
Hope some of you guys will figure out what is wrong with the update and solve
the problem...

Emmanuel
Comment 7 Dave Jones 2005-08-31 19:12:19 EDT
fixed in the latest kernel errata


*** This bug has been marked as a duplicate of 165528 ***
Comment 8 Emmanuel Druon 2005-09-01 02:25:23 EDT
Dave, could you tell me which fixed kernel package version(s) you are talking
about ? 

My FC4 system was updated to the latest packages available and I still have to
downgrade redhat-rpm-config.noarch to produce a usable kernel package ?

Comment 9 Dave Jones 2005-09-04 23:47:36 EDT
the 1447 kernel has a patch to fix the module loader.

Comment 10 Emmanuel Druon 2005-09-05 03:07:40 EDT
nop, 1447 kernel doesn't solve that problem. I've tried to rebuild a kernel
package with this version and it still doesn't work. My only solution is still
to downgrade the redhat-rpm-config.
If someone could confirm this...
Comment 11 Emmanuel Druon 2005-09-05 05:16:44 EDT
Oups, sorry Dave, you can forget about my last post... I confirm that IT WORKS
FINE WITH the 1447 kernel. I must have tried rebuilding the new kernel with the
old version running... I re-installed my "light" FC4 distrib and upgraded
everything all over again, rebooted, rebuilt the kernel and the rebuilded kernel
works fine.
So I bet that it closes the bug.

For those who can't (for some obscure reason) upgrade to the newest kernel,
downgrading the redhat-rpm-config works fine...


Note You need to log in before you can comment on or make changes to this bug.