Bug 1655639 - Unable to update EJB3 resource configuration
Summary: Unable to update EJB3 resource configuration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7
Version: JON 3.3.11
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR03
: One-off release
Assignee: Josejulio Martínez
QA Contact: Filip Brychta
URL:
Whiteboard:
Depends On:
Blocks: 1543522
TreeView+ depends on / blocked
 
Reported: 2018-12-03 15:34 UTC by Filip Brychta
Modified: 2019-01-31 15:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 15:54:14 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1314388 None CLOSED ejb3 -> Strict Max Bean Instance Pool: failed to change configuration parameters 2019-01-19 17:53:13 UTC

Description Filip Brychta 2018-12-03 15:34:38 UTC
Description of problem:
Attempt to update EJB3 resource configuration fails with:
You have to select between derive-size and max-pool-size, both can't be set or unset at the same time

But there are no derive-size or max-pool-size properties available.
derive-size and max-pool-size properties are defined in mdb-strict-max-pool and slsb-strict-max-pool resources but still the error message is not correct because only derive-size is set.

Version-Release number of selected component (if applicable):
JON 3.3.11 + EAP plugin pack 08.CR01

How reproducible:
Always

Steps to Reproduce:
1. start EAP 7 standalone
2. import the EAP 7 standalone from discovery queue
3. run Install RHQ User operation
4. navigate to EAP 7->Subsystems->Container->ejb3->Configuration
5. set Enable Statistics to Yes
6. Save

Actual results:
Update fails with:
You have to select between derive-size and max-pool-size, both can't be set or unset at the same time


Expected results:
Configuration should be successfully updated.

Additional info:
Tried on EAP 7.2 and EAP 7.1

Comment 4 Josejulio Martínez 2019-01-04 15:27:42 UTC
commit e8f582e16ee10ef4e197d9daa8ce0258787edb0a
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Thu Jan 3 22:46:38 2019 -0600

    Bug 1655639 - Unable to update EJB3 resource configuration
     - subsystem=EJB3 doesn't have a derive-size/max-pool-size,
     thus Ejb3Component is not required in this case.
     - Removing default-clustered-sfsb-cache as is read-only and deprecated


Note You need to log in before you can comment on or make changes to this bug.