Bug 1655783 - (process:20531): libnm-WARNING **: 16:36:17.486: no object known for /org/freedesktop/NetworkManager/Devices/8
Summary: (process:20531): libnm-WARNING **: 16:36:17.486: no object known for /org/fre...
Keywords:
Status: CLOSED DUPLICATE of bug 1461572
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.7
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Thomas Haller
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 22:06 UTC by Till Maas
Modified: 2020-03-24 14:49 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 14:49:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Till Maas 2018-12-03 22:06:10 UTC
Description of problem:
When removing a vlan interface, libnm shows a warning

Version-Release number of selected component (if applicable):
1:1.12.0-6.el7

How reproducible:
always

Steps to Reproduce:
1. install nmstate (see https://github.com/nmstate/nmstate)
2. run
nmstatectl set <<EOF
interfaces:
- name: eth1.101
  type: vlan
  state: up
  vlan:
    base-iface: eth1
    id: 101
  ipv4:
    enabled: true
    address:
      - ip: 192.168.23.130
        prefix-length: 31
EOF

3. run
nmstatectl set <<EOF
interfaces:
- name: eth1.101
  type: vlan
  state: absent
EOF


Actual results:
2018-12-03 17:05:07,135 root         DEBUG    Checkpoint /org/freedesktop/NetworkManager/Checkpoint/16 created for all devices: 60
2018-12-03 17:05:07,150 root         DEBUG    Executing NM action: func=_safe_deactivate_async, args=(<NM.DeviceVlan object at 0x7fb60fe1a730 (NMDeviceVlan at 0x1c607b0)>,)
2018-12-03 17:05:07,184 root         DEBUG    Connection deactivation succeeded on eth1.101
2018-12-03 17:05:07,184 root         DEBUG    Executing NM action: func=_safe_delete_async, args=(<NM.DeviceVlan object at 0x7fb60fe1a730 (NMDeviceVlan at 0x1c607b0)>,)
2018-12-03 17:05:07,208 root         DEBUG    Connection deletion succeeded: dev=eth1.101
2018-12-03 17:05:07,208 root         DEBUG    NM action queue exhausted, quiting mainloop

(process:20714): libnm-WARNING **: 17:05:07.212: no object known for /org/freedesktop/NetworkManager/Devices/9

2018-12-03 17:05:07,221 root         DEBUG    State verification passed on attempt #0
2018-12-03 17:05:07,223 root         DEBUG    Checkpoint /org/freedesktop/NetworkManager/Checkpoint/16 destroyed
Desired state applied: 
interfaces:
- name: eth1.101
  type: vlan
  state: absent


Expected results:
no libnm warning

Additional info:
Discussed in
https://github.com/nmstate/nmstate/pull/181

Comment 3 Thomas Haller 2020-03-24 14:49:47 UTC
see also:

https://bugzilla.redhat.com/show_bug.cgi?id=1648195
https://bugzilla.redhat.com/show_bug.cgi?id=1461572

This isn't easy to fix, and not planned for rhel-7.

Closing as duplicate (for rhel-8 bug).

*** This bug has been marked as a duplicate of bug 1461572 ***


Note You need to log in before you can comment on or make changes to this bug.