Bug 1655898 - Include UDF support in rescue ISO when backup is stored on the ISO itself [NEEDINFO]
Summary: Include UDF support in rescue ISO when backup is stored on the ISO itself
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear
Version: 7.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On: 1638857
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 08:54 UTC by Renaud Métrich
Modified: 2019-08-19 14:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-19 14:48:17 UTC
Target Upstream Version:
pcahyna: needinfo? (Lgrunewa)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github rear rear pull 1992 'None' 'closed' 'Include UDF support in rescue ISO when backup is stored on the ISO itself' 2019-11-14 13:15:49 UTC
Red Hat Bugzilla 1462189 'unspecified' 'CLOSED' 'ReaR cannot create ISO images larger than 4GB due to Red Hat change that removes mkisofs' 2019-11-14 13:15:48 UTC
Red Hat Knowledge Base (Solution) 3733861 None None None 2018-12-04 09:20:36 UTC

Internal Links: 1462189

Description Renaud Métrich 2018-12-04 08:54:38 UTC
Description of problem:

When using BACKUP_URL=iso:///backup and ISO generator is mkisofs or genisoimage (RHEL case), include the udf module and enable creating an hybrid iso9660/udf DVD.
This is necessary if the backup archive is >= 4GiB, otherwise the following error occurs:

File ./backup/backup.tar.gz is larger than 4GiB-1.
-allow-limited-size was not specified. There is no way do represent this file size. Aborting.

xorrisofs has not the issue, but since we do not ship xorrisofs, this needs to be fixed.


Version-Release number of selected component (if applicable):

rear-2.4-2.el7


How reproducible:

Always


Steps to Reproduce:
1. Set up rear to embed backup in ISO

  # cat /etc/rear/site.conf
  BACKUP=NETFS
  BACKUP_URL="iso:///backup"
  OUTPUT_URL=null
  ISO_DIR="/home/rmetrich/rear"

2. Create a big file to make sure resulting backup is larger than 4GB

  # dd if=/dev/urandom of=/root/3.2G count=3276 bs=1M

3. Backup the system

  # rear mkbackup


Actual results:

genisoimage 1.1.11 (Linux)
Scanning .
Scanning ./backup
File ./backup/backup.tar.gz is larger than 4GiB-1.
-allow-limited-size was not specified. There is no way do represent this file size. Aborting.
2018-11-30 16:04:57.267620909 ERROR: Could not create ISO image (with /bin/mkisofs)
==== Stack trace ====
Trace 0: /usr/sbin/rear:543 main
Trace 1: /usr/share/rear/lib/mkbackup-workflow.sh:22 WORKFLOW_mkbackup
Trace 2: /usr/share/rear/lib/framework-functions.sh:101 SourceStage
Trace 3: /usr/share/rear/lib/framework-functions.sh:49 Source
Trace 4: /usr/share/rear/output/ISO/Linux-i386/820_create_iso_image.sh:28 source
Trace 5: /usr/share/rear/lib/_input-output-functions.sh:371 StopIfError
Message: Could not create ISO image (with /bin/mkisofs)
== End stack trace ==


Expected results:

No error


Additional info:

GitHub PR: https://github.com/rear/rear/pull/1992

Comment 2 Pavel Cahyna 2018-12-04 10:28:19 UTC
(In reply to Renaud Métrich from comment #0)

> xorrisofs has not the issue, but since we do not ship xorrisofs, this needs
> to be fixed.

We intend to ship xorrisofs, see bz1462189, bz1638857.

Comment 3 Pavel Cahyna 2019-02-08 17:42:12 UTC
Will it still be a problem when we fix bz1655956 by adding xorriso (bz1638857)? I would prefer not having two fixes for the same problem to reduce the amount of testing needed.

Comment 4 Renaud Métrich 2019-02-11 07:39:38 UTC
It will be fixed by fixing xorriso (bz1638857).

Comment 7 Pavel Cahyna 2019-08-19 14:48:17 UTC
The actual problem (files in ISO images larger than 4 GB, bz1462189) was fixed by including xorriso (bz1638857) and moreover after including xorriso the fix proposed here will not work anyway, as xorriso does not have the required option (-allow-limited-size, it does not even have -udf).


Note You need to log in before you can comment on or make changes to this bug.