Bug 1655956 - Automatically exclude $BUILD_DIR from the backup
Summary: Automatically exclude $BUILD_DIR from the backup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear
Version: 7.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Cahyna
QA Contact: David Jež
URL:
Whiteboard:
Depends On:
Blocks: 1677733
TreeView+ depends on / blocked
 
Reported: 2018-12-04 10:20 UTC by Renaud Métrich
Modified: 2019-08-06 13:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1677733 (view as bug list)
Environment:
Last Closed: 2019-08-06 13:12:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2273 None None None 2019-08-06 13:12:31 UTC
Github rear rear pull 1993 'None' 'closed' 'Automatically exclude $BUILD_DIR from the backup' 2019-11-28 13:08:39 UTC
Red Hat Knowledge Base (Solution) 3734241 None None None 2018-12-04 10:24:31 UTC

Description Renaud Métrich 2018-12-04 10:20:53 UTC
Description of problem:

Usually $BUILD_DIR hosted on /tmp and hence automatically excluded from the backup.
When specifying $TMPDIR, $BUILD_DIR was not excluded from the backup.

Version-Release number of selected component (if applicable):

All


How reproducible:

Always


Steps to Reproduce:
1. Specify a TMPDIR alternate directory in environment or /etc/rear/{local,site}.conf

  # mkdir /temporary
  # TMPDIR=/temporary rear mkbackup

2. Check the backup content

  # tar tzvf /path/to/the/backup.tar.gz | grep "^temporary/rear"

Actual results:

  drwxr-xr-x root/root                0 2018-12-04 10:44 temporary/rear.XXX

Expected results:

  No rear temp directory


Additional info:

PR submitted upstream: https://github.com/rear/rear/pull/1993

Comment 5 errata-xmlrpc 2019-08-06 13:12:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2273


Note You need to log in before you can comment on or make changes to this bug.