Bug 1677733 - Automatically exclude $BUILD_DIR from the backup
Summary: Automatically exclude $BUILD_DIR from the backup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rear
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.0
Assignee: Pavel Cahyna
QA Contact: David Jež
URL:
Whiteboard:
Depends On: 1655956
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-02-15 17:59 UTC by Pavel Cahyna
Modified: 2019-11-05 21:04 UTC (History)
4 users (show)

Fixed In Version: rear-2.4-10.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1655956
Environment:
Last Closed: 2019-11-05 21:04:10 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github rear rear pull 1993 'None' 'closed' 'Automatically exclude $BUILD_DIR from the backup' 2019-11-28 13:09:16 UTC
Red Hat Product Errata RHBA-2019:3413 None None None 2019-11-05 21:04:18 UTC

Description Pavel Cahyna 2019-02-15 17:59:29 UTC
+++ This bug was initially created as a clone of Bug #1655956 +++

Description of problem:

Usually $BUILD_DIR hosted on /tmp and hence automatically excluded from the backup.
When specifying $TMPDIR, $BUILD_DIR was not excluded from the backup.

Version-Release number of selected component (if applicable):

All


How reproducible:

Always


Steps to Reproduce:
1. Specify a TMPDIR alternate directory in environment or /etc/rear/{local,site}.conf

  # mkdir /temporary
  # TMPDIR=/temporary rear mkbackup

2. Check the backup content

  # tar tzvf /path/to/the/backup.tar.gz | grep "^temporary/rear"

Actual results:

  drwxr-xr-x root/root                0 2018-12-04 10:44 temporary/rear.XXX

Expected results:

  No rear temp directory


Additional info:

PR submitted upstream: https://github.com/rear/rear/pull/1993

Comment 1 Fedora Blocker Bugs Application 2019-03-04 16:34:27 UTC
Proposed as a Freeze Exception for 30-beta by Fedora user jlanda using the blocker tracking app because:

 Gnome 3.32 changed System folder to Utilities in gnome-shell. This would be great to be fixed for f30

Comment 2 Pavel Cahyna 2019-03-04 16:56:21 UTC
(In reply to Fedora Blocker Bugs Application from comment #1)
> Proposed as a Freeze Exception for 30-beta by Fedora user jlanda using the
> blocker tracking app because:
> 
>  Gnome 3.32 changed System folder to Utilities in gnome-shell. This would be
> great to be fixed for f30

This must be a mistake.

Comment 3 Adam Williamson 2019-03-04 17:08:33 UTC
Yeah, it was a typo by someone using the Fedora blocker bugs webapp - sorry about that.

Comment 4 Pavel Cahyna 2019-05-28 08:26:30 UTC
Moving to 8.1.0, I think 8.0.1 was my mistake. There is not other 8.0.1 bug for ReaR and the branch was not created.

Comment 8 errata-xmlrpc 2019-11-05 21:04:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3413


Note You need to log in before you can comment on or make changes to this bug.