Bug 1656046 - ISO Uploader Tool doesn't work
Summary: ISO Uploader Tool doesn't work
Keywords:
Status: CLOSED DUPLICATE of bug 1627200
Alias: None
Product: ovirt-iso-uploader
Classification: oVirt
Component: General
Version: ---
Hardware: x86_64
OS: Linux
urgent
high vote
Target Milestone: ovirt-4.3.0
: ---
Assignee: Gal Zaidman
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 14:30 UTC by Pedut
Modified: 2019-04-28 09:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 08:48:13 UTC
oVirt Team: Integration
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 95995 0 master ABANDONED Packaging: remove python2/3 pacakges, and require the correct packages insted 2018-12-11 09:14:58 UTC

Description Pedut 2018-12-04 14:30:21 UTC
Description of problem:
ISO Uploader Tool doesn't work.

Version-Release number of selected component (if applicable):
Engine Version: 4.3.0-0.2.el7
OS Version: RHEL - 7.6 - 4.el7
LIBVIRT Version: libvirt-4.5.0-10.el7_6.3
VDSM Version: vdsm-4.30.3-33.el7

How reproducible:
100%

Steps to Reproduce:
1. Try to run any of the commands of the ISO Uploader Tool. 
2.
3.

Actual results:
Traceback (most recent call last):
  File "/usr/bin/engine-iso-uploader", line 32, in <module>
    from .glfs_api import GlfsApi
ValueError: Attempted relative import in non-package


Expected results:
The command works as it should.

Additional info:
[root@compute-ge-6 bin]# engine-iso-uploader -h
Traceback (most recent call last):
  File "/usr/bin/engine-iso-uploader", line 32, in <module>
    from .glfs_api import GlfsApi
ValueError: Attempted relative import in non-package
[root@compute-ge-6 bin]# vi engine-iso-uploader 

It seems like there is a problem with the relative import of .glfs_api

Comment 1 Sandro Bonazzola 2018-12-05 15:46:40 UTC
Gal, can you please look into this?

Comment 2 Gal Zaidman 2018-12-11 07:09:21 UTC
Gerrit patch link:

https://gerrit.ovirt.org/#/c/95995/

Comment 3 Gal Zaidman 2018-12-11 08:48:13 UTC

*** This bug has been marked as a duplicate of bug 1627200 ***


Note You need to log in before you can comment on or make changes to this bug.