Bug 165643 - improper incoming mail reporting
improper incoming mail reporting
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcsh (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Bill Huang
:
: 166659 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 22:20 EDT by Need Real Name
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-17 17:45:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-08-10 22:20:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
There is a problem in the way tcsh reports new received emails. Previously (tcsh-6.12-11.EL3), the shell would show 

You have new mail.

when new mail would arrive for the user. The latest version (tcsh-6.13-9) shows the following:

You have You have %smail.
mail.

I have recompiled the latest tcsh (6.14) and it works fine in reporting new emails to the user. bash works ok also.

Version-Release number of selected component (if applicable):
tcsh-6.13-9

How reproducible:
Always

Steps to Reproduce:
1. send email to user
2. wait a few minutes and press return



Actual Results:  tcsh printed:

You have You have %smail.
mail.


Expected Results:  tcsh should have printed:

You have new mail.

Additional info:
Comment 1 Miloslav Trmač 2005-08-17 17:45:26 EDT
Thanks for your report.

As you already know, this is fixed in tcsh 6.14 and therefore it will be fixed
in RHEL 5.  This is purely a cosmetic issue, so I don't think this warrants an
RHEL 4 erratum.
Comment 2 Suzanne Hillman 2005-08-24 15:13:27 EDT
*** Bug 166659 has been marked as a duplicate of this bug. ***
Comment 3 Miloslav Trmač 2005-08-29 12:44:07 EDT
*** Bug 166659 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.