Bug 166659 - TCSH doesn't print # of messages in mail alert
TCSH doesn't print # of messages in mail alert
Status: CLOSED DUPLICATE of bug 165643
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tcsh (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-24 09:53 EDT by Billy McCarthy
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 12:44:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Billy McCarthy 2005-08-24 09:53:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
When new mail is found TCSH does not report it properly, instead printing 
'You have You have %smail.
mail.'
In /usr/share/local/LC_MESSAGES/tcsh lines 184 and 185 do not have a space between %s and mail, it reads '%smail'.  Which I believe is the source of this error.  Just adding the space creates a new problem though.  

After editing that file, if the user tries to cd into a non-existent directory the error message is wrong.  It is simply 'e.', or if trying to cd into a non-existent directory with a * after it, ie tmp*, 'tmp*: s.'


Version-Release number of selected component (if applicable):
tcsh-6.13-9

How reproducible:
Always

Steps to Reproduce:
1. run tcsh
2. wait for new mail to arrive.
3. OR, edit /usr/share/local/LC_MESSAGES/tcsh 
4. and try to cd into a directory that doesn't exist
  

Actual Results:  after 2: 
'You have You have %smail.
mail.'

after 4: 
'cd tmp
e.' 
OR 
'cd tmp*
tmp*: s.'


Expected Results:  After 2: 'You have mail'
After 4: 
'cd tmp
tmp: No such file or directory.'
OR
'cd tmp*
tmp*: No match.'

Additional info:
Comment 1 Suzanne Hillman 2005-08-24 15:13:18 EDT

*** This bug has been marked as a duplicate of 165643 ***
Comment 3 Suzanne Hillman 2005-08-24 15:16:29 EDT
Sorry; I pattern matched on the weird mail error, and noticed the strange errors
when a directory doesn't exist after I closed as dup.
Comment 5 Miloslav Trmač 2005-08-29 12:44:04 EDT
The catgets() catalogs in /usr/share/locale/*/LC_MESSAGES/tcsh are binary files
and editing them will most likely corrupt them, so the strange error messages are
not suprising.

The mail reporting issue is a code bug (not fixable by editing the catalogs)
and will be fixed in RHEL 5.

Thanks for your report.

*** This bug has been marked as a duplicate of 165643 ***

Note You need to log in before you can comment on or make changes to this bug.