Bug 165670 - hsqldb user creates user account with wrong uid
Summary: hsqldb user creates user account with wrong uid
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hsqldb   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Keywords:
: 169364 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-08-11 10:10 UTC by Mephisto
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: hsqldb-1.80.1-1jpp_3fc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 09:12:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mephisto 2005-08-11 10:10:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050729 Fedora/1.1-0.2.5.deerpark.alpha2 Firefox/1.0+

Description of problem:
During installation, hsqldb creates a user called hsqldb and a group with the same name, but this user got the uid of 501 (in the user account range), causing it to appear on the gdm login screen. The same thing applies to the group id.

Version-Release number of selected component (if applicable):
hsqldb-1.80.1-1jpp_1fc

How reproducible:
Didn't try

Steps to Reproduce:
1. Install hsqldb
  

Actual Results:  a user has been created with a user-account uid (501 on my system) (same thing for gid)

Expected Results:  a user should have been created with a low uid and gid, like somewhere in the 100's.

Additional info:

Comment 1 Gary Benson 2005-09-30 08:24:07 UTC
*** Bug 169364 has been marked as a duplicate of this bug. ***

Comment 2 Jeremy Katz 2005-10-17 14:56:55 UTC
Gary -- it would be very good to have this fixed for test1 which is fast
approaching...

Comment 3 Gary Benson 2005-10-18 08:40:04 UTC
What uid and gid should I use?

Comment 4 Chris Lumens 2005-10-20 17:40:51 UTC
In your preinstall scriptlet, use groupadd -r, which will make groupadd use the
first availble gid lower than 499.  You are already using this on the useradd
command so I think you should be good on both counts if you fix up the groupadd.

Comment 5 Willem Riede 2005-10-26 22:59:56 UTC
When I installed fc5-devel on my x86_64, hsqldb %post created an 
ordinary user - as opposed to a system one with uid below 500 - 
which screwed up my NFS mounts as "wriede" is 500 on all my other 
systems. 


install.log:Installing hsqldb-1.80.1-1jpp_1fc.x86_64.
install.log.syslog:<86>Oct 15 17:18:19 groupadd[4985]: new group: name=hsqldb,
GID=500
install.log.syslog:<86>Oct 15 17:18:19 useradd[4986]: new user: name=hsqldb,
UID=500, GID=500, home=/var/lib/hsqldb, shell=/bin/sh


I also noted that a skeleton was created in /var/lib/hsqldb:

total 100
drwxr-xr-x   4 hsqldb hsqldb 4096 Oct 15 17:18 .
drwxr-xr-x  19 root   root   4096 Oct 22 11:16 ..
-rw-r--r--   1 hsqldb hsqldb   24 Oct 15 17:18 .bash_logout
-rw-r--r--   1 hsqldb hsqldb  191 Oct 15 17:18 .bash_profile
-rw-r--r--   1 hsqldb hsqldb  124 Oct 15 17:18 .bashrc
drwxr-xr-x   2 hsqldb hsqldb 4096 Aug  4 06:45 data
-rw-r--r--   1 hsqldb hsqldb  120 Oct 15 17:18 .gtkrc
drwxr-xr-x   2 root   root   4096 Oct 15 17:18 lib
-rw-r--r--   1 root   root    289 Aug  4 06:45 server.properties
-rw-------   1 hsqldb hsqldb 4301 Aug  4 06:45 sqltool.rc
-rw-r--r--   1 root   root    315 Aug  4 06:45 webserver.properties
-rw-r--r--   1 hsqldb hsqldb  658 Oct 15 17:18 .zshrc


I believe useradd should be run with both the -r and the -M flag

Comment 6 Gary Benson 2005-10-27 08:48:25 UTC
This should be fixed in hsqldb-1.80.1-1jpp_2fc and later.

Comment 7 Willem Riede 2005-10-27 22:00:14 UTC
I can confirm that this works OK with hsqldb-1.80.1-1jpp_3fc


Note You need to log in before you can comment on or make changes to this bug.