Bug 1656982 - missing screenshots in gnome software description
Summary: missing screenshots in gnome software description
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: 8.0
Assignee: Martin Pitt
QA Contact: Jan Ščotka
URL:
Whiteboard:
Depends On: 1673011 1690277
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 19:25 UTC by Matthias Clasen
Modified: 2019-06-14 01:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-14 01:40:11 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Matthias Clasen 2018-12-06 19:25:19 UTC
Some issues I noticed with a RHEL8beta test install today.

I'm sorry if most of these are known and already worked on.

- Cockpit shows up in GNOME Software without screenshot

- The launch button does nothing

- Launching subscription manager brings up empty firefox

- After figuring out how to start cockpit, I get a cockpit UI in firefox, but it is less than ideal. It asks me to log in as "server user", while I am already on my desktop...

- After logging in, I get "Retrieving subscription status" which seems to last forever

Comment 1 Martin Pitt 2018-12-06 20:08:12 UTC
Thanks for your report! But this includes several different and unrelated issues.

> Cockpit shows up in GNOME Software without screenshot

I'm fairly sure this got fixed with https://github.com/cockpit-project/cockpit/commit/5556bf8a918252536130b . I. e. will be in release 184 next Wednesday.

> The launch button does nothing

What do you mean by that?

> Launching subscription manager brings up empty firefox

This is a duplicate of bug 1651621 (and its depending bug 1651264)

> It asks me to log in as "server user", while I am already on my desktop...

This is indeed a sad user experience. The new solution that we have in above bug avoids that entirely.

> After logging in, I get "Retrieving subscription status" which seems to last forever

This is then an issue in the subscription-manager-cockpit package, i. e. should be filed against the "subscription-manager" component.

As all the other issues are handled elsewhere, I devote this report to track the missing screenshots.

Comment 3 Martin Pitt 2019-02-06 13:10:13 UTC
This still needs an appstream-data refresh.


Note You need to log in before you can comment on or make changes to this bug.