Bug 1657836 - gradle: FTBFS in Fedora rawhide
Summary: gradle: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gradle
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stewardship SIG
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
: 1675056 1735307 (view as bug list)
Depends On:
Blocks: F31FTBFS 1698510 1732841
TreeView+ depends on / blocked
 
Reported: 2018-12-10 14:32 UTC by Mikolaj Izdebski
Modified: 2020-01-22 21:01 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-13 15:09:19 UTC
Type: Bug


Attachments (Terms of Use)

Description Mikolaj Izdebski 2018-12-10 14:32:22 UTC
Description of problem:
Package gradle fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
4.4.1-1.fc30

Steps to Reproduce:
koji build --scratch f30 gradle-4.4.1-1.fc30.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/gradle

Comment 1 Miro Hrončok 2019-04-01 23:53:05 UTC
Could not resolve all files for configuration ':codeQuality:compileClasspath'.
> Could not resolve com.google.code.findbugs:findbugs:2.0.1.
  Required by:
      project :codeQuality
   > Could not resolve com.google.code.findbugs:findbugs:2.0.1.
      > Could not parse POM /usr/share/maven-poms/JPP-findbugs.pom
         > java.lang.UnsupportedOperationException (no error message)
   > No cached version of com.google.code.findbugs:findbugs:2.0.1 available for offline mode.
   > No cached version of com.google.code.findbugs:findbugs:2.0.1 available for offline mode.
   > No cached version of com.google.code.findbugs:findbugs:2.0.1 available for offline mode.
   > Could not resolve com.google.code.findbugs:findbugs:2.0.1.
      > Could not parse POM /usr/share/maven-poms/JPP-findbugs.pom
         > java.lang.UnsupportedOperationException (no error message)

gradle 4.4.1-1 was built with gradle 4.3.1 - since then, it doesn't build (with 4.4.1).

Comment 2 Mikolaj Izdebski 2019-04-02 06:35:42 UTC
Known issue. The root cause is that XMvn does not implement required method: https://github.com/fedora-java/xmvn/blob/fd43eb6/xmvn-connector-gradle/src/main/java/org/fedoraproject/xmvn/connector/gradle/GradleResolver.java#L325

Comment 3 Miro Hrončok 2019-04-18 07:47:52 UTC
Possible workaround:

Tag gradle-4.3.1 into rawhide before building newver version of gradle.

$ koji tag-build f31-pending gradle-4.3.1-8.fc29
$ koji wait-repo f31-build --build=gradle-4.3.1-8.fc29
$ fedpkg build

For F30:

$ koji tag-build f30-updates-candidate gradle-4.3.1-8.fc29
$ bodhi overrides save gradle-4.3.1-8.fc29 --wait
$ fedpkg build

Comment 4 Miro Hrončok 2019-04-18 09:09:42 UTC
*** Bug 1675056 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Release Engineering 2019-04-26 23:24:26 UTC
Dear Maintainer,

your package has not been built successfully in f30. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
can be orphaned if this bug remains in NEW state more than 8 weeks.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 6 Miro Hrončok 2019-04-27 08:24:04 UTC
gradle-4.4.1-3.fc30 https://koji.fedoraproject.org/koji/buildinfo?buildID=1188746

This was built, but by a workaround, hence we keep this open. Changing to ASSIGNED to avoid automatic reminders.

Comment 7 Miro Hrončok 2019-07-31 19:38:59 UTC
*** Bug 1735307 has been marked as a duplicate of this bug. ***

Comment 8 Mohan Boddu 2019-08-08 13:25:50 UTC
The following builds were made: gradle-4.4.1-3.fc30 gradle-4.4.1-3.fc31

Comment 9 Fabio Valentini 2019-08-13 15:09:19 UTC
gradle has been retired for fedora 31+.

If somebody un-retires it, they will have to deal with this anyway.

Comment 10 W. Michael Petullo 2020-01-22 21:01:26 UTC
Just for the record, and with the understanding that packages are orphaned because they lack volunteers: I would like to package Ghidra (https://ghidra-sre.org/) for Fedora, but Ghidra requires gradle to build.


Note You need to log in before you can comment on or make changes to this bug.