Bug 1657933 - python-cryptography >= 1.9 is missing from client tools channels
Summary: python-cryptography >= 1.9 is missing from client tools channels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cryptography
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: z4
: 13.0 (Queens)
Assignee: Lon Hohberger
QA Contact: nlevinki
URL:
Whiteboard:
: 1657937 (view as bug list)
Depends On: 1657935 1657938 1657940
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 18:51 UTC by Lon Hohberger
Modified: 2019-01-16 17:54 UTC (History)
5 users (show)

Fixed In Version: python-cryptography-2.1.4-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1657935 1657937 1657938 1657940 (view as bug list)
Environment:
Last Closed: 2019-01-16 17:54:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0088 None None None 2019-01-16 17:54:20 UTC

Description Lon Hohberger 2018-12-10 18:51:05 UTC
Description of problem:

The python2-pyOpenSSL package should require cryptograhy >= 1.9, but does not. This version is the correct version to be used with pyOpenSSL in OSP13 

Version-Release number of selected component (if applicable): python-cryptography-2.1.4-3.el7ost


How reproducible: 100%

Steps to Reproduce:
1. Enable the OpenStack Platform 13 Server, Workstation, or Client Tools repositories
2. dnf install python-cryptography

Actual results:
Cryptography version 1.3 is installed from RHEL

Expected results:
Cryptography version 2.1.4 is installed from Red Hat OpenStack Platform 13 Tools repository

Comment 1 Lon Hohberger 2018-12-10 18:59:08 UTC
*** Bug 1657937 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2019-01-16 17:54:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0088


Note You need to log in before you can comment on or make changes to this bug.