Bug 1657977 - [UI] Gray out multiQueues check box in Instance Types 'New/Edit' option - make it clear that enabled by default
Summary: [UI] Gray out multiQueues check box in Instance Types 'New/Edit' option - mak...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.7
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ovirt-4.3.2
: 4.3.0
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-10 21:43 UTC by Abhishekh Patil
Modified: 2019-05-08 12:39 UTC (History)
8 users (show)

Fixed In Version: ovirt-engine-4.3.2
Doc Type: Bug Fix
Doc Text:
Previously, the "Multi Queues enabled" checkbox was missing from the New- or Edit Instance Types window in the Administration Portal. The current release fixes this issue.
Clone Of:
Environment:
Last Closed: 2019-05-08 12:39:09 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1085 None None None 2019-05-08 12:39:19 UTC
oVirt gerrit 97968 master MERGED webadmin: Show multi queue check box in instance type 2019-02-25 11:12:56 UTC

Description Abhishekh Patil 2018-12-10 21:43:46 UTC
Description of problem:

'Multi Queues enabled' checkbox is missing from Instance Types 'New/Edit' option. 


Version-Release number of selected component (if applicable):

ovirt-engine-4.2.7. 

How reproducible:
[100%]

Steps to Reproduce:
1. Go to 'Administration' ==> 'Configure' ==> 'Instance Types' ==> 'New/Edit' 
2. Click on 'Resource Allocation' ==> Under 'Queues' option, 'Multi Queues enabled' checkbox is not present, only ⓘ hover tag is present. 


Actual results:

'Multi Queues enabled' checkbox is not present in Instance Types 'New/Edit' option.

Expected results:

'Multi Queues enabled' checkbox should be present in 'Instance Types' option.

Comment 5 Dominik Holler 2019-02-14 17:16:05 UTC
The 'Multi Queues enabled' checkbox is hidden by intention in the Instance Types dialogs.

Comment 6 Dan Kenigsberg 2019-02-19 10:58:12 UTC
(In reply to Dominik Holler from comment #5)
> The 'Multi Queues enabled' checkbox is hidden by intention in the Instance
> Types dialogs.

I suspect that we have disabled this on the instance type, because we have good defaults which we'd like everybody to use. We still let users disable this on a specific VM, though, on the hopefully-rare occasion that our default is wrong.


I believe that we could be visually better if we keep the queues checkbox, but have it disabled, so that it is clearer what the (i)nfo icon refers to.


Abhishekh Patil, can you find out if/why does the customer want to modify the number of queues per vNIC?

Comment 7 Dominik Holler 2019-02-19 12:18:17 UTC
(In reply to Dan Kenigsberg from comment #6)
> 
> I believe that we could be visually better if we keep the queues checkbox,
> but have it disabled, so that it is clearer what the (i)nfo icon refers to.
> 

I think this would be more transparent to the user, too.

Comment 8 Michael Burman 2019-02-19 14:05:45 UTC
I would also suggest that if we going to disable the queues checkbox, then the blue icon tooltip should say that. It should say that multiqueues are not available via instance type.

Comment 9 Abhishekh Patil 2019-02-20 06:54:56 UTC
(In reply to Dan Kenigsberg from comment #6)
> (In reply to Dominik Holler from comment #5)
> > The 'Multi Queues enabled' checkbox is hidden by intention in the Instance
> > Types dialogs.
> 
> I suspect that we have disabled this on the instance type, because we have
> good defaults which we'd like everybody to use. We still let users disable
> this on a specific VM, though, on the hopefully-rare occasion that our
> default is wrong.
> 
> 
> I believe that we could be visually better if we keep the queues checkbox,
> but have it disabled, so that it is clearer what the (i)nfo icon refers to.
> 
> 
> Abhishekh Patil, can you find out if/why does the customer want to modify
> the number of queues per vNIC?

It is not about the need of this option, but this option is still available if we edit the VM and navigate to Edit -> Resource Allocation and it not present when checking from Administration -> Instance Types. 

In the rhvm GUI, if we open the 'edit' UI for a VM and navigate to 'Resource Allocation', under the queues section there is a checkbox labeled 'Multi Queues Enabled', which dictates whether RHEV gives each vNIC a single queue or multiple based on the number of vCPUs available to that VM.

Under Administration -> Instance Types, both the create and edit interfaces have an ⓘ hover which displays information about this checkbox, suggesting you should be able to set it for an Instance Type so all VMs created with said type as a basis are correctly configured at creation time. The checkbox itself is missing, however, preventing you from configuring this setting.

Comment 10 Dan Kenigsberg 2019-02-20 08:52:03 UTC
> It is not about the need of this option...

> ... preventing you from configuring this setting.

I am confused by your reply. May I ask again: does the customer want to disable this option for the whole instance type? if so, why?

Comment 11 Abhishekh Patil 2019-02-20 13:06:19 UTC
(In reply to Dan Kenigsberg from comment #10)
> > It is not about the need of this option...
> 
> > ... preventing you from configuring this setting.
> 
> I am confused by your reply. May I ask again: does the customer want to
> disable this option for the whole instance type? if so, why?

They expecting that this option should exist for the whole instance type. They are trying to create VM using the instance type which has multi queues enabled.

Comment 12 Dominik Holler 2019-02-21 08:41:36 UTC
(In reply to Abhishekh Patil from comment #11)
> (In reply to Dan Kenigsberg from comment #10)
> > > It is not about the need of this option...
> > 
> > > ... preventing you from configuring this setting.
> > 
> > I am confused by your reply. May I ask again: does the customer want to
> > disable this option for the whole instance type? if so, why?
> 
> They expecting that this option should exist for the whole instance type.
> They are trying to create VM using the instance type which has multi queues
> enabled.

Multi queues are enabled by default, so they would need only to modify the
instance type, if they want to disable multi queues.

So let's modify the UI in a way, that this would be obvious by showing the
checked multi queues option grayed out in the instance type dialogs.

Comment 13 Martin Tessun 2019-02-21 10:07:05 UTC
So my understanding:

- We want to show the multiqueue option in Instance Types but it is greyed out (and ticked).
- We do not want customers to change that option in instance types as it is the most sensible default. (C#6)
- As hiding the option was intentionally in the first place (C#5) we want to keep this behaviour.
- Users can still change the multiqueue option on a per VM basis (and probably on a template basis, too).

If that is the case, I am fine with the approach.

Comment 18 Michael Burman 2019-03-06 08:46:51 UTC
Verified on - rhvm-4.3.2-0.1.el7.noarch

Ales, for the tooltip fix, i reported BZ 1685876

Comment 20 errata-xmlrpc 2019-05-08 12:39:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1085


Note You need to log in before you can comment on or make changes to this bug.