Bug 1658161 - kernel backtrace issue, aarch64 specific
Summary: kernel backtrace issue, aarch64 specific
Keywords:
Status: CLOSED DUPLICATE of bug 1658163
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: systemtap
Version: 8.0
Hardware: aarch64
OS: Linux
low
low
Target Milestone: rc
: 8.0
Assignee: Frank Ch. Eigler
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-11 12:24 UTC by Martin Cermak
Modified: 2018-12-11 12:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-11 12:54:08 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Cermak 2018-12-11 12:24:56 UTC
After the KASLR was introduced in rhel7.5 as the default, problem bz1572501 with kernel backtraces showed up.  That time it was fixed on all the supported arches except for s390x.  Now I see similar problem on rhel8 aarch64.  It is sort of a regression from the user POV because it works on rhel7 aarch64:

=======
 8.0 Server aarch64 # stap --all-modules -vwe 'probe kernel.function("kmem_cache_alloc") { print_backtrace(); exit() }'
Pass 1: parsed user script and 457 library scripts using 105728virt/86464res/9408shr/77632data kb, in 310usr/20sys/327real ms.
Pass 2: analyzed script: 1 probe, 2 functions, 0 embeds, 0 globals using 154624virt/139456res/10368shr/126528data kb, in 970usr/140sys/1108real ms.
Pass 3: using cached /root/.systemtap/cache/4c/stap_4cba6977c29c496ae360951f465419ca_2403.c
Pass 4: using cached /root/.systemtap/cache/4c/stap_4cba6977c29c496ae360951f465419ca_2403.ko
Pass 5: starting run.
 0xffff0000082a6e40 : kmem_cache_alloc+0x0/0x210 [kernel]
 0x0 (inexact)
Pass 5: run completed in 10usr/50sys/1053real ms.
 8.0 Server aarch64 # 
 8.0 Server aarch64 # uname -r
4.18.0-50.el8.aarch64
 8.0 Server aarch64 # stap -V
Systemtap translator/driver (version 4.0/0.174, rpm 4.0-6.el8)
Copyright (C) 2005-2018 Red Hat, Inc. and others
This is free software; see the source for copying conditions.
tested kernel versions: 2.6.18 ... 4.19-rc7
enabled features: AVAHI BPF JAVA PYTHON3 LIBRPM LIBSQLITE3 NLS NSS READLINE
 8.0 Server aarch64 #
=======

Comment 1 Martin Cermak 2018-12-11 12:54:08 UTC
I've hit some HTTP problems when submitting the bug.  In result this one is a dupe of bz1658163.

*** This bug has been marked as a duplicate of bug 1658163 ***


Note You need to log in before you can comment on or make changes to this bug.