Bug 165819 - IBM ACPI extensions hosed after updating ACPI
IBM ACPI extensions hosed after updating ACPI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 167078 (view as bug list)
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-12 11:46 EDT by Joachim Frieben
Modified: 2015-01-04 17:21 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 05:56:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2005-08-12 11:46:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Epiphany/1.6.3

Description of problem:
After upgrading to kernel-2.6.12-1.1420_FC4, there is no
"ibm" entry in "/proc/acpi" anymore. Curiously, there is
still an "ibm_acpi.ko" module present in "/lib/modules/2.6.12-1.1398_FC4/kernel/drivers/acpi" but
it cannot be loaded.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1420_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install "kernel-2.6.12-1.1420_FC4".
2. Boot up system.
3. Check "/proc/acpi".
  

Actual Results:  The IBM extensions to ACPI are not available.

Expected Results:  The IBM extensions to ACPI should be available.

Additional info:

Compiling "ibm-acpi-0.11" forthis kernel version leads
to the following compilation error:

make -C /lib/modules/2.6.12-1.1420_FC4/build SUBDIRS=/home/install/build/ibm-acpi-0.11 modules
make[1]: Entering directory `/usr/src/kernels/2.6.12-1.1420_FC4-i686'
  CC [M]  /home/install/build/ibm-acpi-0.11/ibm_acpi.o
/home/install/build/ibm-acpi-0.11/ibm_acpi.c:1756: error: conflicting types for
‘device_add’
include/linux/device.h:317: error: previous declaration of ‘device_add’ was heremake[2]: *** [/home/install/build/ibm-acpi-0.11/ibm_acpi.o] Error 1
make[1]: *** [_module_/home/install/build/ibm-acpi-0.11] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.12-1.1420_FC4-i686'
make: *** [default] Error 2

It seems that "ibm-acpi" has not been updated to work with
the ACPI update of 20050729.
Comment 1 Joachim Frieben 2005-08-12 11:57:14 EDT
Sorry, I obviously meant to write:

"Curiously, there is still an "ibm_acpi.ko" module present in
"/lib/modules/2.6.12-1.1420_FC4/kernel/drivers/acpi" but
it cannot be loaded."
Comment 2 Dave Jones 2005-08-26 18:45:58 EDT
Can you try the errata kernel in updates-testing please ? That has an ACPI
update which may fix your problem.
Comment 3 Dave Jones 2005-08-29 21:18:43 EDT
*** Bug 167078 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Saltzman 2005-08-29 21:41:04 EDT
To which errata kernel in updates-testing are you referring?  There are a few,
and all are lower release numbers than kernel-2.6.12-1.1447_FC4 (which has the
same issue, as noted in Bug 167078).
Comment 5 Dave Jones 2005-08-29 22:56:58 EDT
That comment was made before 1447 got pushed to final updates.
Comment 6 Giuseppe Castagna 2005-09-05 16:35:04 EDT
Yes but the problem persists with 1447 (on my Thinkpad X40)

[root@myrte beppe]# uname -a
Linux myrte 2.6.12-1.1447_FC4 #1 Fri Aug 26 20:29:51 EDT 2005 i686 i686 i386
GNU/Linux
[root@myrte beppe]# modprobe -v ibm_acpi
insmod /lib/modules/2.6.12-1.1447_FC4/kernel/drivers/acpi/ibm_acpi.ko
FATAL: Error inserting ibm_acpi
(/lib/modules/2.6.12-1.1447_FC4/kernel/drivers/acpi/ibm_acpi.ko): No such device
Comment 7 Joachim Frieben 2005-09-06 03:50:55 EDT
No improvement for ACPI updates of kernel-2.6.12-1.1450_FC4. The "ibm-acpi"
package (v0.8 to v0.11) seems to lag behind and needs to be adapted to the
current ACPI trunk.
Comment 8 Dana Canfield 2005-09-09 01:12:42 EDT
FWIW, the ibm_acpi.ko loads just fine under the 2.6.11 kernel that was released
with FC4.  All errata kernels numbered 2.6.12 break this.  
Comment 9 Matthew Saltzman 2005-09-09 05:22:52 EDT
Are you sure?  It worked perfectly for me (T41) from kernel-2.6.11-1.1369_FC4
through kernel-2.6.12-1.1398_FC4:

$ uname -r
2.6.12-1.1398_FC4
$ lsmod |grep ibm_acpi
ibm_acpi               15997  0
$ dmesg | grep ibm_acpi
ibm_acpi: IBM ThinkPad ACPI Extras v0.8
ibm_acpi: http://ibm-acpi.sf.net/
ibm_acpi: dock device not present

But it broke for me when I installed kernel-2.6.12-1.1447_FC4.  Obviously, it
broke for the OP at kernel-2.6.12-1.1420_FC4 (which I never tried).
Comment 10 Dana Canfield 2005-09-09 23:16:05 EDT
Nope, not sure at all. :-)  I think I tested the other three kernels but missed
this one.  I can indeed confirm that the included 0.8 ibm_acpi as well as the
0.10 from the web site both load fine in 2.6.12-1.1398.

Sorry for the incorrect info. 
Comment 11 Joachim Frieben 2005-09-14 14:30:59 EDT
Issue resolved for kernel-2.6.13-1.1552_FC5. "ibm-acpi" received an
update from Len Brown (v0.12a). Will hopefully apply to FC4 as soon as
2.6.13 is considered stable enough.
Comment 12 David Perkinson 2005-09-24 00:51:06 EDT
This bug persists 2.6.12-1.1456_FC4 as tested on my thinkpad x40, which means I
keep running kernel 2.6.12-1.1398_FC4.  Is there a workaround for this, or
should I wait for kernel 2.6.13?
Comment 13 Dave Jones 2005-09-24 01:29:38 EDT
There's a preview of the 2.6.13 kernel in updates-testing right now if you want
to try that (though it may have other problems too right now, which is why its
in -testing, not -final yet)
Comment 14 Noa Resare 2005-09-29 16:06:29 EDT
I can confirm that using kernel-2.6.13-1.1524_FC4.i686.rpm from -testing
restores the ability to load the ibm_acpi module. Tested on an ThinkPad T30.
Comment 15 Matthew Saltzman 2005-09-29 16:22:37 EDT
Same here on T41.  So far (after the latest updates-testing
selinux-policy-targeted) it looks like all functionality is restored.  From the
boot messages, it looks like there have been some changes in ibm_acpi.  Do they
affeect functionality?
Comment 16 Dave Jones 2005-09-30 03:26:25 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 17 Matthew Saltzman 2005-09-30 05:39:00 EDT
Apparently fixed in 2.6.13-1.1526_FC4.
Comment 18 David Perkinson 2005-10-01 01:38:53 EDT
After upgrading to 2.6.13-1.1526_FC4, /proc/acpi/sleep no longer exists, so I am
no longer able to suspend.  I have no problem with 2.6.12-1.1398_FC4.
Comment 19 Matthew Saltzman 2005-10-01 07:26:39 EDT
(In reply to comment #18)
> After upgrading to 2.6.13-1.1526_FC4, /proc/acpi/sleep no longer exists, so I am
> no longer able to suspend.  I have no problem with 2.6.12-1.1398_FC4.

See bug #169200.  Not sure how we were all supposed to have divined this change,
but that solution works fine.
Comment 20 David Perkinson 2005-10-01 12:25:14 EDT
(In reply to comment #19)
> (In reply to comment #18)
> ...
> See bug #169200.  Not sure how we were all supposed to have divined this change,
> but that solution works fine.

Yes, that works.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.