Bug 167078 - kernel-2.6.12-1.1447_FC4 won't load ibm_acpi module
kernel-2.6.12-1.1447_FC4 won't load ibm_acpi module
Status: CLOSED DUPLICATE of bug 165819
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-29 21:07 EDT by Matthew Saltzman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 21:18:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2005-08-29 21:07:15 EDT
Description of problem:
kernel-2.6.12-1.1447_FC4 fails to load the ibm_acpi module on boot.  This
prevents ACPI functions such as sleep, hotkeys, etc. from working.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1447_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot kernel-2.6.12-1.1447_FC4 on a Thinkpad
2. lsmod | grep ibm_acpi
3.
  
Actual results:
ibm_acpi is not loaded

Expected results:
ibm_acpi should be loaded

Additional info:
This is a regression from kernel-2.6.12-1.1398_FC4, which works perfectly.

Attempting to load the module by hand produces:
# modprobe -v ibm_acpi
insmod /lib/modules/2.6.12-1.1447_FC4/kernel/drivers/acpi/ibm_acpi.ko
ibm_acpi: Using generic hotkey driver
FATAL: Error inserting ibm_acpi
(/lib/modules/2.6.12-1.1447_FC4/kernel/drivers/acpi/ibm_acpi.ko): No such device
Comment 1 Dave Jones 2005-08-29 21:18:30 EDT

*** This bug has been marked as a duplicate of 165819 ***

Note You need to log in before you can comment on or make changes to this bug.