Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1658296

Summary: Installing OpenShift with Ansible playbook fails on invalid option for include_tasks
Product: Red Hat Enterprise Virtualization Manager Reporter: Ivana Saranova <isaranov>
Component: ovirt-engine-metricsAssignee: Shirly Radco <sradco>
Status: CLOSED WONTFIX QA Contact: Lukas Svaty <lsvaty>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 4.2.8CC: aoconnor, ratamir, sradco
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-19 11:39:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Metrics RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 1646154    

Description Ivana Saranova 2018-12-11 17:14:49 UTC
Description of problem:
When installing metrics according to this guide: https://ovirt.org/documentation/metrics-install-guide/ the deploy_cluster.yml playbook fails on invalid option for include_tasks. 

Version-Release number of selected component (if applicable):
ansible 2.7.4
ovirt-engine-4.2.8-0.1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Do all task according to the guide until chapter "Running Ansible" step 5
2. Run:

ANSIBLE_LOG_PATH=/tmp/ansible.log ansible-playbook -vvv -e @/root/vars.yaml -i /root/ansible-inventory-ocp-latest-aio playbooks/deploy_cluster.yml

3. Fails with error:

fatal: [localhost]: FAILED! => {
    "reason": "Invalid options for include_tasks: component\n\nThe error appears to have been in '/usr/share/ansible/openshift-ansible/roles/openshift_logging/tasks/generate_certs.yaml': line 135, column 3, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n- name: Generate PEM certs\n  ^ here\n"
}

Failure summary:


  1. Hosts:    localhost
     Play:     OpenShift Aggregated Logging
     Task:     openshift_logging : include_tasks
     Message:  Failed without returning a message.



Actual results: Playbook fails


Expected results: 


Additional info:

Comment 2 Sandro Bonazzola 2019-01-28 09:40:52 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 4 Raz Tamir 2019-01-31 12:16:25 UTC
(In reply to Sandro Bonazzola from comment #2)
> This bug has not been marked as blocker for oVirt 4.3.0.
> Since we are releasing it tomorrow, January 29th, this bug has been
> re-targeted to 4.3.1.

Sandro,

This bug is a test blocker for the rsyslog replacement.

Can we do something about it?
(Adding a blocker flag)

Comment 6 Shirly Radco 2019-02-19 11:39:34 UTC
Closing this since we are now working on the new metrics store installation, based on OpenShift 3.11.
This is not relevant anymore, OpenShift 3.9 installation is broken.