Bug 165859 - Gnome window list does not switch workspaces when app is clicked
Gnome window list does not switch workspaces when app is clicked
Status: CLOSED DUPLICATE of bug 165658
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-12 17:17 EDT by Nick Atkins
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 14:48:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Atkins 2005-08-12 17:17:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
When I click on an applications's icon in the Gnome window list it does not switch to the workspace in which the app is running it simply transfers the app to the current workspace.  This renders the whole workspace concept useless as all windows eventually end up in the same workspace!

This is a regression from an up2date as this was not happening until recently (last few days).

Version-Release number of selected component (if applicable):
2.10.1

How reproducible:
Always

Steps to Reproduce:
1. add workspace switcher and window list applets to gnome panel.  ensure "show windows from all workspaces" is selected
2. open two different app windows and ensure they are in different workspaces
3. select one of the workspaces and click on the other app in the window list


Actual Results:  window moves from native workspace to current

Expected Results:  workspace should have switched to the one containing the second app window.

Additional info:
Comment 1 Nick Atkins 2005-08-16 19:59:53 EDT
Was this bug fixed by Gnome bug no. 166379
(http://bugzilla.gnome.org/show_bug.cgi?id=166379)?  Will there be a backport to
2.10.1 ?
Comment 2 Mark McLoughlin 2005-08-18 10:45:16 EDT
What version of gtk2 is this?
Comment 3 Nick Atkins 2005-08-18 11:30:22 EDT
My FC4 rpm reports version 2.6.7-4.
Comment 4 Mark McLoughlin 2005-08-18 11:48:50 EDT
What's the metacity version?
Comment 5 Nick Atkins 2005-08-18 11:56:08 EDT
metacity 2.10.3-1
Comment 6 Mark McLoughlin 2005-08-18 12:05:42 EDT
Weird. The problem is either metacity or gtk2 - since metacity has been updated
recently, I'll pick that, but I thought this was fixed in 2.10.3
Comment 7 Levente Farkas 2005-08-18 14:27:59 EDT
no! the latest metacity has this bug while if you donwgrade to the previous
version (which still in the updates directory of fc4) the bug disapear! please
release a bugfix metacity for this!
Comment 8 Graham Cole 2005-08-24 02:41:24 EDT
I downgraded to the previous metacity, and it is a definite improvement, but I
still see this behavior when there is only one window open.
Comment 9 Ray Strode [halfline] 2005-09-13 14:48:07 EDT

*** This bug has been marked as a duplicate of 165658 ***

Note You need to log in before you can comment on or make changes to this bug.