Bug 165658 - Restore to native workspace do not work
Restore to native workspace do not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
: 165859 166490 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 05:06 EDT by Lars E. Pettersson
Modified: 2007-11-30 17:11 EST (History)
9 users (show)

See Also:
Fixed In Version: libwnck-2.10.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 17:44:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
_NET_ACTIVE_WINDOW patch culprit (1.75 KB, text/plain)
2005-09-09 06:40 EDT, Didier
no flags Details

  None (edit)
Description Lars E. Pettersson 2005-08-11 05:06:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
After the update to metacity-2.10.3-1 the window list option "restore to native workspace" do not work. "Clicking" on the application in the window list restores the application to the current workspace.


Version-Release number of selected component (if applicable):
metacity-2.10.3-1

How reproducible:
Always

Steps to Reproduce:
1.Update metacity to latest version (2.10.3-1)
2.Put an application on another workspace window
3.Click on the application in the window list


Actual Results:  The application is put on current workspace

Expected Results:  It should be opened on the native workspace (as this is the chosen action in "window list preferences" on my system)

Additional info:
Comment 1 Robert Walsh 2005-08-13 17:16:45 EDT
Yup - happens here, too.  Really REALLY annoying.
Comment 2 Rosen Nedialkov 2005-08-25 15:56:54 EDT
Happens on both my FC4 machines after metacity update. VERY ANNOYING !!! Feels
like I have no virtual desktops.
Comment 3 Sumit Khanna 2005-09-08 11:05:31 EDT
*** Bug 166490 has been marked as a duplicate of this bug. ***
Comment 4 Didier 2005-09-09 06:09:42 EDT
Seems this has been discussed in http://bugzilla.gnome.org/show_bug.cgi?id=128380 .
The changed behaviour was introduced in Metacity 2.10.3
(http://www.linuxcompatible.org/Metacity_2.10.3_s51685.html), and reverted back
in Metacity 2.11.1 (http://www.linuxcompatible.org/Metacity_2.11.1_s51713.html).


Would it be sustainable to release a Fedora patch for 2.10.3, as the current
2.10.3 behaviour renders the gnome-panel "Window-List" applet preferences useless ?
Comment 5 Didier 2005-09-09 06:40:54 EDT
Created attachment 118629 [details]
_NET_ACTIVE_WINDOW patch culprit

Seems the attached patch (extract from
http://ftp.gnome.org/pub/GNOME/sources/metacity/2.10/metacity-2.10.2-2.10.3.diff.gz)
is the culprit.

The patch looks to be reverted in
http://ftp.gnome.org/pub/GNOME/sources/metacity/2.11/metacity-2.11.0-2.11.1.diff.gz
, but I have no idea whether it would patch cleanly against the Fedora
metacity-2.10.3 rpm.

Another pointer :
http://cvs.gnome.org/viewcvs/metacity/src/window.c?r1=1.388&r2=1.389
Comment 6 Ray Strode [halfline] 2005-09-09 16:07:52 EDT
Hey guys,

I've pushed an update for libwnck that may solve your problems.

Can you try installing the libwnck rpms from testing:

http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/4/

and tell me if it addresses your problems?
Comment 7 Dumitru Ciobarcianu 2005-09-09 16:48:57 EDT
It's fixed for me:

[cioby@DustPuppy cioby]$ rpm -q metacity libwnck
metacity-2.10.3-1
libwnck-2.10.0-4.fc4
Comment 8 Ray Strode [halfline] 2005-09-09 16:51:19 EDT
Hi Dumitru,
 
libwnck-2.10.0-4.fc4 or libwnck-2.10.0-4.fc4.1 ?
Comment 9 Dumitru Ciobarcianu 2005-09-09 17:37:14 EDT
[cioby@DustPuppy cioby]$ rpm -q libwnck
libwnck-2.10.0-4.fc4
[cioby@DustPuppy cioby]$

I did an "yum --enablerepo updates-testing update"
Maybe my local mirror does not have yet the fc4.1 version
Comment 10 Dumitru Ciobarcianu 2005-09-09 18:31:40 EDT
Sorry for the spam, it's not fixed, not even with fc4.1 :(
Comment 11 Robert Walsh 2005-09-09 21:13:57 EDT
Still borked for me, too.
Comment 12 Victor Bogado 2005-09-10 11:25:01 EDT
this libwnck-2.10.0-4.fc4 do not solve the problem. The patch Didier Moens
posted here seem to make this behaviour the designed one. I guess that this
means that if the window list wants to keep the window in it's current workspace
it must change the current workspace to the native one <i>before</i> activating
the window.

From the info in libwnck it states that it is responsible for the way pagers
act, so I'm guessing that Ray Strode's libwnck was altered to behave like that,
but it didn't work. 

I am really anoyed by this behaviour change. I want to help, where can I get the
sources for this libwnck so I could try to do some "good"? I will, as soon as
finishing here search the src rpm in the testing area. 
Comment 13 Didier 2005-09-13 10:54:49 EDT
Just a confirmation : as to be expected, reverting to metacity-2.10.0-2.fc4
reestablishes Window List's "Restore to native workspace" functionality.
Comment 14 Ray Strode [halfline] 2005-09-13 14:48:23 EDT
*** Bug 165859 has been marked as a duplicate of this bug. ***
Comment 15 Ray Strode [halfline] 2005-09-13 14:54:14 EDT
Hi guys,

So the problem is that metacity 2.10.3 really only works right with libwnck
2.10.3.  

I've added libwnck 2.10.3 to the testing updates queue (so it should show up
later today or tomorrow).  When it does, can you guys test it and confirm that
it fixes the problem?

After that, I'll push the update out of testing.
Comment 16 Didier 2005-09-13 16:20:45 EDT
Tested with metacity-2.10.3-1 and libwnck-2.10.3-1  ; Window List "Restore to
native workspace" confirmed fixed.
Thanks !
Comment 17 Ray Strode [halfline] 2005-09-13 17:44:08 EDT
Hi Didier,

Great.  I've queued it for fc4-updates.
Comment 18 Robert Walsh 2005-09-16 22:26:20 EDT
Works here, too.

Note You need to log in before you can comment on or make changes to this bug.