Bug 165880 - scriptlet issues
scriptlet issues
Status: CLOSED DUPLICATE of bug 165803
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-13 10:44 EDT by Joe Orton
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-17 22:34:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2005-08-13 10:44:43 EDT
Split from bug 165803:

1. %post has lots of output to stdout.  All scriptlets should be silent.

[root@tango RPMS]# rpm -ivh tog-pegasus-2.4.1-1.i386.rpm
Preparing...                ########################################### [100%]
   1:tog-pegasus            ########################################### [100%]
 Generating SSL certificates...
 To start Pegasus manually:
 /etc/init.d/tog-pegasus start
 Stop it:
 /etc/init.d/tog-pegasus stop
 To set up PATH and MANPATH in /etc/profile
 run /opt/tog-pegasus/sbin/settogpath.
[root@tango RPMS]#

2. %post should not be logging:

mkdir -p /var/opt/tog-pegasus/log
echo `date` >/var/opt/tog-pegasus/log/install.log 2>&1

and the .../log the directory should be package-managed not created by %post.
And it should be in /var/log but hey.

3. %postun does "rm -rf /opt/tog-pegasus", and more -- totally unacceptable. 
This is a workaround for creating all the symlinks, perhaps?  /opt/tog-pegasus
is packaged.  It shouldn't need to be removed manually in %postun.  It should
not remove *all* configuration files from /etc/opt/tog-pegasus, either, again
very bad practice; remove just the config files which are automatically created
by %post perhaps.

4. there should be a "Requires(post): " line listing all the things the %post
script requires: openssl, lsb, etc.  likewise for other scriptlets.

5. the symlinks from .so.N to .so should not be created in %post - they should
be packaged in the -devel^W-sdk subpackage.
Comment 1 Jason Vas Dias 2005-08-17 22:34:59 EDT
All the above issues are now fixed with tog-pegasus-2.4.1-2.rhel4 - 
see bug 165803 .


*** This bug has been marked as a duplicate of 165803 ***

Note You need to log in before you can comment on or make changes to this bug.