Bug 165883 - The partition�s data region doesn�t occupy the entire partition
Summary: The partition�s data region doesn�t occupy the entire partition
Status: CLOSED DUPLICATE of bug 159047
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 4
Hardware: powerpc
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-13 15:18 UTC by ssrjdg
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 18:45:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ssrjdg 2005-08-13 15:18:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.6 (KHTML, like Gecko) Safari/125.12

Description of problem:
Trying to set up dual-boot Mac OS X Tiger/FC4 system
iMac G3 500MHz 20GB 384MB
Partitioned drive into two identical 9.4GB HFS+ partitions
Installed Mac OS X Tiger (10.4) no problem
Booted iMac from CD 1 of 5 CD FC4 set
Chose English as language and US English keyboard, clicked 'Next' and receive the firs error message:
"The partitions data region doesnt occupy the entire partition"
Selected 'Ignore' 5 times and then received the next message:
"Attempt to read sectors 16-18 outside of partition on /dev/hda"
Kept clicking "ignore" 3 times.  Kept up this procedure with the following results
5 x first error
2 x second error
3 x first error

Got to Disk Druid:

This time round I tried to delete the first partition (128MB foreign)

Received the following unhandled exception:

Traceback (most recent call last):
 File /usr/lib/anaconda/iw/partition_gui.py, line 952, in deleteCb
   self.refresh()
 File /usr/lib/anaconda/iw/partition_gui.py, line 985, in refresh
  autopart.doPartitioning(self.diskset, self.partitions)
 File /usr/lib/anaconda/autopart.py, line 1024, in doPartitioning
  deletePart(diskset, delete)
 File /usr/lib/anaconda/autopart.py, line 902, in deletePart
  disk = diskset.disks[delete.drive]
KeyError, hda

I hope this helps


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Partitioned drive into two identical 9.4GB HFS+ partitions
2.Booted iMac from CD 1 of 5 CD FC4 set
3.Chose English as language and US English keyboard, clicked 'Next' and receive the firs error message:
"The partitions data region doesnt occupy the entire partition"
Selected 'Ignore' 5 times and then received the next message:
"Attempt to read sectors 16-18 outside of partition on /dev/hda"
Kept clicking "ignore" 3 times.  Kept up this procedure with the following results
5 x first error
2 x second error
3 x first error
4. Anything I try using Disk Druid fails with an unhandled exception
  

Actual Results:  Unhandled exception error:
Traceback (most recent call last):
 File /usr/lib/anaconda/iw/partition_gui.py, line 952, in deleteCb
   self.refresh()
 File /usr/lib/anaconda/iw/partition_gui.py, line 985, in refresh
  autopart.doPartitioning(self.diskset, self.partitions)
 File /usr/lib/anaconda/autopart.py, line 1024, in doPartitioning
  deletePart(diskset, delete)
 File /usr/lib/anaconda/autopart.py, line 902, in deletePart
  disk = diskset.disks[delete.drive]
KeyError, hda

Expected Results:  Partition should have been erased.
Wanted to set as Apple Bootstrap partion of 1MB

Additional info:

Comment 1 Jeremy Katz 2005-08-15 18:45:52 UTC

*** This bug has been marked as a duplicate of 159047 ***


Note You need to log in before you can comment on or make changes to this bug.