Bug 1659020 - isync: can't verify some ssl certificates (e.g. imap.gmail.com)
Summary: isync: can't verify some ssl certificates (e.g. imap.gmail.com)
Keywords:
Status: CLOSED DUPLICATE of bug 1632958
Alias: None
Product: Fedora
Classification: Fedora
Component: isync
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-13 11:27 UTC by Evgeni Golov
Modified: 2018-12-13 11:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-13 11:28:20 UTC
Type: Bug


Attachments (Terms of Use)

Description Evgeni Golov 2018-12-13 11:27:25 UTC
Description of problem:

$ mbsync -V redhat.com
Reading configuration file /home/egolov/.mbsyncrc
C: 0/4  B: 0/3  M: +0/0 *0/0 #0/0  S: +0/0 *0/0 #0/0
Channel redhat.com-default
Opening master store redhat.com-remote...
Resolving imap.gmail.com... ok
Connecting to imap.gmail.com (173.194.76.109:993)... 
Opening slave store redhat.com-local...
SSL error connecting imap.gmail.com (173.194.76.109:993): self signed certificate


Version-Release number of selected component (if applicable):
isync-1.3.0-3.fc29.x86_64

How reproducible:
100%

Steps to Reproduce:
1. try to connect to imap.gmail.com with IMAPS (Host imap.gmail.com, SSLType IMAPS)


Actual results:
SSL error connecting imap.gmail.com (173.194.76.109:993): self signed certificate


Expected results:
Connection succeeds and mail gets synced

Additional info:
This is fixed upstream in https://sourceforge.net/p/isync/isync/ci/17babc1695e82ca80d032b79e920fcb86ede2347/, but there seems to be no new release of the 1.3 branch yet.

Comment 1 Evgeni Golov 2018-12-13 11:28:20 UTC

*** This bug has been marked as a duplicate of bug 1632958 ***


Note You need to log in before you can comment on or make changes to this bug.