Bug 1632958 - isync fails to sync to gmail with TLS and SNI
Summary: isync fails to sync to gmail with TLS and SNI
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: isync
Version: 29
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Fabian Affolter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1659020 1662065 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-25 22:26 UTC by Chris Irwin
Modified: 2019-07-18 10:58 UTC (History)
16 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-06-08 00:58:11 UTC


Attachments (Terms of Use)
patch I'm using in a local build (888 bytes, patch)
2018-10-29 10:25 UTC, Christophe Fergeau
no flags Details | Diff

Description Chris Irwin 2018-09-25 22:26:28 UTC
Description of problem:
Attempting to sync a gmail imap account fails with a certificate verification error. The apparent cause is isync not supporting SNI.

Version-Release number of selected component (if applicable):
1.3.0-3.fc29

How reproducible:
Every time

Steps to Reproduce:
1. Configure isync to sync remote gmail mailbox to local maildir
2. Run isync

Actual results:
SSL error connecting imap.gmail.com ([2607:f8b0:4001:c20::6d]:993): self signed certificate


Expected results:
Connecting to imap.gmail.com ([2607:f8b0:4001:c12::6d]:993)...

Additional info:
Found a discussion on Arch Linux forum: https://bbs.archlinux.org/viewtopic.php?id=240429

References a fix upstream: https://sourceforge.net/p/isync/isync/ci/17babc1695e82ca80d032b79e920fcb86ede2347/tree/src/socket.c?diff=f698f16967ae8341ff4b506f96b8cd5790c05d27

Additionally, forcing TLSv1.1 seems to work around the issue.

Comment 1 Daniel Stone 2018-10-08 09:07:55 UTC
It would be great if this patch could be pulled so isync could work with GMail again. I would've prepared an update in a COPR, but fedpkg is currently refusing to start: https://pagure.io/fedpkg/issue/286

Comment 2 Amy Watson 2018-10-09 12:03:36 UTC
When I have used the version of mbsync which is in the Ubuntu 13.10 so it worked fine except it does not sync only Gmail sent mail even I have changed the setting of Gmail Account. Anyone can tell me the solution of this problem. Once, I didn’t recover deleted message accidentally then I visited this site https://www.gmailtechnicalsupportnumbers.com/optimum-email-support/ and resolved my issue.

Comment 3 Christophe Fergeau 2018-10-29 10:25 UTC
Created attachment 1498465 [details]
patch I'm using in a local build

This backports the patch fixing that issue.

Comment 4 Christophe Fergeau 2018-10-29 10:36:14 UTC
It's missing

+BuildRequires:  git-core
+BuildRequires:  perl-TimeDate

Scratch build with these changes at https://koji.fedoraproject.org/koji/taskinfo?taskID=30540567

Comment 5 Thorsten Scherf 2018-11-08 12:08:28 UTC
Temporary workaround is to add 'SSLVersions TLSv1.1' to '~/.mbsyncrc'.

Comment 6 Evgeni Golov 2018-12-13 11:28:20 UTC
*** Bug 1659020 has been marked as a duplicate of this bug. ***

Comment 7 Rafael Ávila de Espíndola 2019-05-08 19:25:23 UTC
This issue is still present on fedora 30

Comment 8 Christophe Fergeau 2019-05-13 06:53:48 UTC
*** Bug 1662065 has been marked as a duplicate of this bug. ***

Comment 9 Christophe Fergeau 2019-05-13 06:57:02 UTC
Can we get a build with the patch fixing this issue?

Comment 10 Fedora Update System 2019-05-30 09:36:25 UTC
FEDORA-2019-a3e996a0ab has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a3e996a0ab

Comment 11 Fedora Update System 2019-05-30 09:47:04 UTC
FEDORA-2019-d71a467141 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d71a467141

Comment 12 Fedora Update System 2019-05-30 09:57:10 UTC
FEDORA-EPEL-2019-6fc3c83374 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6fc3c83374

Comment 13 Fedora Update System 2019-05-31 00:53:04 UTC
isync-1.3.1-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a3e996a0ab

Comment 14 Fedora Update System 2019-05-31 01:36:46 UTC
isync-1.3.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6fc3c83374

Comment 15 Fedora Update System 2019-05-31 03:00:15 UTC
isync-1.3.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d71a467141

Comment 16 Fedora Update System 2019-06-08 00:58:11 UTC
isync-1.3.1-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2019-06-08 02:13:09 UTC
isync-1.3.1-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2019-06-15 00:24:53 UTC
isync-1.3.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 19 James Bondela 2019-07-18 09:59:09 UTC Comment hidden (spam)
Comment 20 abdul aziz 2019-07-18 10:58:18 UTC Comment hidden (spam)

Note You need to log in before you can comment on or make changes to this bug.