Bug 165939 - Add new Chinese font name in fonts.conf
Summary: Add new Chinese font name in fonts.conf
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fontconfig   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Blocker 177889
TreeView+ depends on / blocked
 
Reported: 2005-08-15 03:43 UTC by Leon Ho
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 2.3.92.cvs20051129-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-23 05:16:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a proposed patch (1.46 KB, patch)
2005-09-21 03:31 UTC, Akira TAGOH
no flags Details | Diff
Patch for fontconfig spec file (987 bytes, patch)
2006-01-17 05:04 UTC, Tim Mayberry
no flags Details | Diff
New Patch to fontconfig default config file (5.71 KB, patch)
2006-01-17 05:06 UTC, Tim Mayberry
no flags Details | Diff
New version of the 50-no-hint-fonts.conf file (4.56 KB, text/plain)
2006-01-17 05:09 UTC, Tim Mayberry
no flags Details

Description Leon Ho 2005-08-15 03:43:56 UTC
Description of problem:
There is a new Chinese font on the pipe and it will be built very soon. Would
you please add those font name into fonts.conf so that it can be fallback correctly?

If existing fonts.conf has this,
                <family>AR PL SungtiL GB</family>
                <family>AR PL Mingti2L Big5</family>

Please add this in front of those two font names:
                <family>AR PL ShanHeiSun Uni</family>

If existing fonts.conf has this,
                <family>AR PL KaitiM GB</family>
                <family>AR PL KaitiM Big5</family>

Please add this in front of those two font names:
                <family>AR PL ZenKai Uni</family>

Comment 1 Akira TAGOH 2005-09-21 03:31:34 UTC
Created attachment 119059 [details]
a proposed patch

It would be better to provide a patch to get this fix quickly.

Comment 2 Akira TAGOH 2005-09-21 03:37:00 UTC
set Proirity to high because new Chinese fonts has already been replaced. this
bug needs to be fixed ASAP.

Comment 4 Akira TAGOH 2005-11-16 05:03:58 UTC
ping again. this isn't yet fixed in rawhide. please let us know if you need any
help for this. thanks.

Comment 5 Carl Worth 2005-12-09 22:02:59 UTC
I'm (finally) doing the work on this (and I apologize about the excessive
delay). The patch provided disagrees with the instructions in the original bug
report in one instance. In one place the patch has:

+                       <family>AR PL Zenkai Uni</family>
                        <family>AR PL SungtiL GB</family>
                        <family>AR PL Mingti2L Big5</family>

While the instructions would suggest that the addition should instead be:

+                       <family>AR PL ShanHeiSun Uni</family>

From what I can tell, this appears to be within the sans-serif aliases within
fonts.conf.

Can anyone suggest to me which is the correct fix here?

Thanks,

-Carl

PS. If someone has instructions I could use for veirfying that my fix works,
that might be useful too.

Comment 6 Carl Worth 2005-12-09 23:32:30 UTC
I just released version 2.3.92.cvs20051129-2 with the change as in the patch.

If that was wrong, I'll be glad to spin this again with the fix.

(And quicker this time, I promise.)

-Carl


Comment 7 Tim Mayberry 2005-12-23 06:18:00 UTC
I think the patch to fonts.conf in the current fontconfig is incorrect. The AR
PL Zenkai Uni font should be aliased as a serif font and the AR PL ShanHeiSun
Uni should be aliased to a sans-serif font.

Comment 8 Ray Strode [halfline] 2006-01-11 16:54:30 UTC
I'll see what I can do about fixing this, unless you want to look at it Carl?

Comment 9 Leon Ho 2006-01-16 06:47:20 UTC
Tim, could you make a new patch for Ray to apply it in the current fontconfig
package? Thanks.

Comment 10 Tim Mayberry 2006-01-17 05:04:50 UTC
Created attachment 123284 [details]
Patch for fontconfig spec file

Patch to Correct aliasing and disable hinting for the two Chinese font names.

Comment 11 Tim Mayberry 2006-01-17 05:06:41 UTC
Created attachment 123285 [details]
New Patch to fontconfig default config file

Fix aliasing of Chinese fonts

Comment 12 Tim Mayberry 2006-01-17 05:09:55 UTC
Created attachment 123286 [details]
New version of the 50-no-hint-fonts.conf file

Disables hinting for the 2 new Chinese fonts and changed all occurances of
rh_prefer_bitmap to new embeddedbitmap fontconfig option.

Comment 13 Ray Strode [halfline] 2006-01-18 16:34:45 UTC
Hi Tim,

I applied your patches last night.  Can you guys test the packages in rawhide
and make sure they are working right? If so, we can close this bug.

Comment 14 Tim Mayberry 2006-01-19 01:13:00 UTC
It looks correct to me, as I understand it LANG=zh_.UTF-8 fc-match should return 
uming.ttf: "AR PL ShanHeiSun Uni" "Regular" as this font has embedded bitmaps
and is one of the reasons why this bug is blocking bug 167383. Can someone else
familiar with these fonts verify that they are now aliased correctly.

Comment 15 Lawrence Lim 2006-01-23 05:16:06 UTC
Verified with fontconfig-2.3.93-4 in zh_TW locale, confirmed hinting has been
disabled.


Note You need to log in before you can comment on or make changes to this bug.