Bug 1659560 - SELinux is preventing certwatch from 'write' accesses on the directory /dev/hugepages.
Summary: SELinux is preventing certwatch from 'write' accesses on the directory /dev/h...
Keywords:
Status: CLOSED DUPLICATE of bug 1659558
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:90771bce2ba2ac6817b2d31d7bc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-14 16:45 UTC by John Griffiths
Modified: 2019-01-08 13:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-08 13:34:35 UTC


Attachments (Terms of Use)

Description John Griffiths 2018-12-14 16:45:25 UTC
Description of problem:
SELinux is preventing certwatch from 'write' accesses on the directory /dev/hugepages.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that certwatch should be allowed write access on the hugepages directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'certwatch' --raw | audit2allow -M my-certwatch
# semodule -X 300 -i my-certwatch.pp

Additional Information:
Source Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
Target Context                system_u:object_r:hugetlbfs_t:s0
Target Objects                /dev/hugepages [ dir ]
Source                        certwatch
Source Path                   certwatch
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-48.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.19.6-200.fc28.x86_64 #1 SMP Sun
                              Dec 2 18:03:32 UTC 2018 x86_64 x86_64
Alert Count                   36
First Seen                    2018-12-12 03:11:06 EST
Last Seen                     2018-12-14 03:30:13 EST
Local ID                      53e07d71-0716-44f5-9e08-ea9302df0117

Raw Audit Messages
type=AVC msg=audit(1544776213.932:69098): avc:  denied  { write } for  pid=15458 comm="certwatch" name="/" dev="hugetlbfs" ino=19691 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hugetlbfs_t:s0 tclass=dir permissive=0


Hash: certwatch,certwatch_t,hugetlbfs_t,dir,write

Version-Release number of selected component:
selinux-policy-3.14.1-48.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.19.6-200.fc28.x86_64
type:           libreport

Potential duplicate: bug 1655351

Comment 1 Lukas Vrabec 2019-01-08 13:34:35 UTC

*** This bug has been marked as a duplicate of bug 1659558 ***


Note You need to log in before you can comment on or make changes to this bug.