Bug 165957 - Review Request: esmtp. Relay only MTA.
Review Request: esmtp. Relay only MTA.
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
David Lawrence
http://esmtp.sourceforge.net/
:
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2005-08-15 06:21 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-23 08:39:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2005-08-15 06:21:27 EDT
SRPM Name or Url: http://www.environnement.ens.fr/docs/fc-srpms/esmtp-0.5.1-3.src.rpm
Description: 

ESMTP is a user configurable relay-only Mail Transfer Agent (MTA) with a
sendmail-compatible syntax. It's based on libESMTP supporting the AUTH
(including the CRAM-MD5 and NTLM SASL mechanisms) and the StartTLS SMTP
extensions.

So these are ESMTP features:
 * requires no administration privileges
 * individual user configuration
 * sendmail command line compatible
 * supports the AUTH SMTP extension, with the CRAM-MD5 and NTLM SASL
   mechanisms
 * support the StartTLS SMTP extension
 * does not receive mail, expand aliases or manage a queue
Comment 1 Patrice Dumas 2005-08-15 06:34:12 EDT
I took the upstream spec tweaked it a little. I used the alternative  system
copying what is done for exim, so that it can be a sendmail replacement and
provide smtpdaemon. It might not be a good idea as fetchmail requires a
smtpdaemon that listen on the smtp port as a fallback in case the mda don't
accept mail,
so it is not a real replacement for smtpdaemon which corresponds with 2
(orthogonal) things, a send mail MTA and a SMTP receiving daemon.

See for example
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=66396#c4
Comment 2 Patrice Dumas 2005-08-15 06:35:56 EDT
I have a better srpm with a Source url that works:

http://www.environnement.ens.fr/docs/fc-srpms/esmtp-0.5.1-4.src.rpm
Comment 3 Aurelien Bompard 2005-08-25 12:16:04 EDT
* I would advise against providing smtpdaemon, since esmtp is not a daemon at
all, and programs like fetchmail could think their requirement is fulfilled
while it is not (nothing listening on port 25)

* Don't put the german translation in the filename. IIRC the policy it not to
include translations except if the package is strongly related to a particular
language (which is not the case here)

* Spec file encoding should be either ASCII UTF-8, but I think this will be
solved when the german parts are gone.

* PreReq should be Requires(post)

* Missing BuildRequires: openssl-devel

* To copy source 1 I would just do "cp %{SOURCE1} mutt-esmtp ." since the
working directory is the building dir, but that's minor.
Comment 4 Patrice Dumas 2005-08-26 09:11:22 EDT
I removed the provide smtpdaemon, now the drawback is that mutt require
smtpdaemon, so a smtp listener must be installed even though none is needed.   

I changed the german accents to utf-8, and then put the translations in comments
such that they are not lost.

The PreReq came from exim.spec... Thanks for the explanation.

openssl-devel is not BuildRequired, it is a dependency for libesmtp-devel. I
filled a bug against libesmtp.

I copy the mutt-esmtp now in the %setup using your command.

See the srpm here:
http://www.environnement.ens.fr/docs/fc-srpms/esmtp-0.5.1-5.src.rpm
Comment 5 Aurelien Bompard 2005-08-26 09:28:56 EDT
> I removed the provide smtpdaemon, now the drawback is that mutt require
> smtpdaemon, so a smtp listener must be installed even though none is needed.

Right... I don't know what the best solution would be, maybe you should ask
fedora-extras-list...

> openssl-devel is not BuildRequired, it is a dependency for libesmtp-devel. I
> filled a bug against libesmtp.

You're right, but the package won't build in the buildsystem as long as
openssl-devel is not buildrequired in a way or another. Could you add the BR
temporarily and remove it when libesmtp-devel is fixed ?

The spec file is still not utf-8 :
$ file esmtp.spec
esmtp.spec: ISO-8859 English text

you can use "recode ISO-8859-1..UTF-8 esmtp.spec" to convert it

Apart from that everything looks OK.
Comment 6 Patrice Dumas 2005-08-26 16:43:25 EDT
Regarding smtpdaemon I think it is not a terrible issue, lets keep it like this.

Hopefully the utf8 issue is solved and I added the BR in:

http://www.environnement.ens.fr/docs/fc-srpms/esmtp-0.5.1-6.src.rpm
Comment 7 Aurelien Bompard 2005-08-28 13:05:10 EDT
Looks good :
* RPM name is OK
* Spec change looks OK
* Source esmtp-0.5.1.tar.bz2 is the same as upstream
* The BuildRoot is the preferred one
* Builds fine in mock
* rpmlint agrees
* Seems to be working fine
Comment 8 Aurelien Bompard 2005-08-28 17:22:30 EDT
According to http://fedoraproject.org/wiki/PackageReviewGuidelines, I was
mistaken about the german translation. Please re-enable it before or after
importing into CVS. Thanks
Comment 9 Patrice Dumas 2005-08-31 17:14:55 EDT
I reenabled the german translations and built. 
Comment 10 Patrice Dumas 2006-07-21 16:25:04 EDT
Aurelien, you should assign that bug to yourself.
Comment 11 Aurelien Bompard 2006-07-23 08:39:22 EDT
Done, thanks

Note You need to log in before you can comment on or make changes to this bug.