Bug 16596 - (Trident blade3d): problems both with xf3 and xf4
(Trident blade3d): problems both with xf3 and xf4
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 16681 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-19 14:55 EDT by giulioo
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 02:57:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X config files (30.00 KB, application/octet-stream)
2000-08-21 03:50 EDT, giulioo
no flags Details

  None (edit)
Description giulioo 2000-08-19 14:55:41 EDT
Xconfigurator set up my XF86config for Acer54e (blade 3d).

startx, X starts at 640x480, I can ctrl_alt_+ to get 800x600.


Then I edit XF86config and change
        Modes       "640x480" "800x600"

to
        Modes        "800x600" "640x480"


X does not start anymore, the monitor goes blank, but not failsafe or 
something to protect the monitor (light would go yellow); Light stays 
green and monitor stays black.

To get 800x600 I have to start at 640x480 and then switch to 800x600.
Comment 1 Trond Eivind Glomsrxd 2000-08-19 15:04:04 EDT
You are kidding now, right? Please tell me you are.

You sure you did the right thing when changing the file?
Does it work if you just specify the 800x600 as the only resolution?
If so, we can always say that this is the reason for writing 640x480 first ;)

Also, if this really is happening I would expect to be an X bug (or simply
buggy/broken hardware)
Comment 2 giulioo 2000-08-21 03:47:56 EDT
I attach the 2 config files.

With 640x480 -> 800x600 (config1) I start at 640 and can switch back and forth 
to 800x600.
With 800x600 -> 640x480 (config2) I start blank and can switch back and forth 
to 680x480 (switch between black screen and 640x480).

If I try a config with just 800x600 it starts blank and stop.

I understand it's very difficult for you to try to debug such a thing, so if 
you close this I'll take no further action.
But what should I do? This is the 2nd monitor I'm trying.
This afternoon I'll try another one (AcerFP551) that is in the Xconfigurator 
list.

Comment 3 giulioo 2000-08-21 03:50:20 EDT
Created attachment 2779 [details]
X config files
Comment 4 Trond Eivind Glomsrxd 2000-08-21 15:40:46 EDT
Try Xconfigurator 4.3.53+ at http://people.redhat.com/teg/xc/ , and specify
"--preferxf4".
Comment 5 giulioo 2000-08-22 04:24:34 EDT
I've tried the new Xconfigurator.

1) even if I start it with --preferxf4 it sets the /etc/X11/X link to the 3.6 
server

2) even if I start it with --preferxf4, it refuses to start if the 3.6 SVGA 
server is not installed

3) I made /etc/X11/X --> /usr/X11R6/bin/XFree86 (hope this is correct) and then 
I could start v4.0 straight at 800x600 (thing that is not possible with v3.6); 
however as soon as I try ctrl_alt_+/- the system hangs and I have to reboot.

You'll say "be happy and stay at 800x600" :-).
But there are problems (like the ones I have with 3.6):  if you open any window 
you see that the vertical lines are not perfectly drawn, it seems the monitor 
is not set up 100% correctly.
The same monitor is perfect under win98.

So, I think I'll give up on this. You can close this.
Later today I'll try v.40 with #16681.

Is there a list of combinations of videocard and monitors that you have tested 
in house so that I can try asking my boss to buy them and be sure they will 
work out of the box? I just want to get at least 800x600@75, no games, no 3d, 
nothing more.
I've looked at the hardware compatibility list of rh62, but I didn't see 
monitors listed.

Comment 6 Trond Eivind Glomsrxd 2000-08-22 13:09:18 EDT
"--preferxf4" works in 4.3.54, from the same place. Which server would you
prefer?

The server/driver being broken is probably an X issue... I'll change components.
Comment 7 giulioo 2000-08-22 17:18:48 EDT
3 for reliability, 4 for "performance"; So basically it's 3.

More details

=== v3:
Cannot start at 800x600.
Can start at 640 and then switch to 800.
Vertical lines of windows are not straigth/regular.
===

=== v4:
Can start directly at 800x
Vertical lines of windows are not straigth/regular.

IMPORTANT NOTE: v4 regularly hangs the system (power cycle needed) running 
xvidtune or ctrl_alt_+/-.
===


See bug 16681 for similar results.
Comment 8 giulioo 2000-08-23 11:11:42 EDT
You were right when saying it was an XFree86 problem.

Today I've tried the same Acer54e monitor and an OlidataMR1502 on an i810 
system (using the updated i810_drv.o from rc1 updates, the rc1 one has some 
issues); they work perfectly now.
Acer54e is set up 800x600@85; it goes straigth to 800x600 with no problem.

So, it seems the problem is that Trident Blade3D is not a good card for 
Linux/XFree86.

You can close this bug. I didn't do it myself because I didn't know how to 
close: deferred, wontfix, notabug?


Comment 9 Trond Eivind Glomsrxd 2000-08-23 14:51:38 EDT
No need to close it - it is a bug which I'm pretty sure will be deferred, but
it's not "fixed".
Comment 10 giulioo 2001-01-03 13:06:58 EST
7.1beta1:

blade3d+Acer54e (Acer54eL)

anaconda and Xconfigurator try xf3 by default. Both of them fail to configure 
the card appropriately, because the X tests (anaconda and Xconfigurator) and 
startx give blank screen (not powersave)

Xconfigurator --preferxf4 is able to set up the card so that X starts, but 
there is a lot of noise; it's usable but just for testing purposes.

As I've learnt (different monitors and same results), this is due to poor 
support for the blade3d in X, or to me having a bad blade3d (works ok in 
windows, though).

Comment 11 giulioo 2001-01-03 13:07:48 EST
*** Bug 16681 has been marked as a duplicate of this bug. ***
Comment 12 giulioo 2001-01-19 08:01:01 EST
FWIW, FloBeta2 GUI install, though it works and does its job, has video-noise 
problems, while FloBeta1 had not.
Comment 13 Mike A. Harris 2001-06-12 02:57:00 EDT
The XFree86 4.1.0 release contains updated Trident support.  I don't know
if it fixes this problem or not, but it might be worth testing in a month
or so.
Comment 14 giulioo 2001-08-13 07:09:23 EDT
Roswell (first beta of this cycle I could try due to cd media problems) is much 
better:
1- for the first time anaconda didn't hang when testing X config
2- screen image is acceptable in kde and gnome; you can work with it and your 
eyes would not suffer. Quality is like Windows.
3- xvidtune does not hang the system anymore

So it seems this can be closed.

Note You need to log in before you can comment on or make changes to this bug.