Bug 165970 - rhythmbox crash when attempting to "Import Folder ..."
rhythmbox crash when attempting to "Import Folder ..."
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 09:09 EDT by James Laska
Modified: 2013-09-02 02:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 09:09:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2005-08-15 09:09:26 EDT
RPM  rhythmbox-0.8.8-3.i386
DEPS 
atk-1.10.1-1.i386
GConf2-2.11.90-1.i386
glib2-2.8.0-1.i386
gnome-vfs2-2.11.90-3.i386
gstreamer-0.8.10-1.i386
gstreamer-plugins-0.8.9-2.i386
gtk2-2.7.5-1.i386
libart_lgpl-2.3.17-2.i386
libbonobo-2.10.0-1.i386
libbonoboui-2.10.0-1.i386
libglade2-2.5.1-2.i386
libgnome-2.11.2-1.i386
libgnomecanvas-2.11.1-1.i386
libgnomeui-2.11.2-1.i386
libxml2-2.6.20-1.i386
ORBit2-2.12.2-1.i386
pango-1.9.1-1.i386
popt-1.10.2-3.i386
zlib-1.2.2.2-5.i386

How to reproduce:
  1) start rhythmbox
  2) select "Music -> Import Folder"   ....  CRASH

Other information:
  I am able to import a local folder by specifying the path in the "Import
Location" dialog.  I have included the gdb backtrace information below.  Please
advise if you would like additional debugging details.

(gdb) bt
#0  0x00a6f35a in strcmp () from /lib/libc.so.6
#1  0x004d4f8b in gtk_file_chooser_dialog_new_with_backend ()
   from /usr/lib/libgtk-x11-2.0.so.0
#2  0x004dc550 in gtk_file_chooser_dialog_new_with_backend ()
   from /usr/lib/libgtk-x11-2.0.so.0
#3  0x004ca9ef in gtk_file_chooser_get_current_folder ()
   from /usr/lib/libgtk-x11-2.0.so.0
#4  0x004e0a06 in gtk_file_chooser_dialog_new_with_backend ()
   from /usr/lib/libgtk-x11-2.0.so.0
#5  0x004ca9ef in gtk_file_chooser_get_current_folder ()
   from /usr/lib/libgtk-x11-2.0.so.0
#6  0x004e0a06 in gtk_file_chooser_dialog_new_with_backend ()
   from /usr/lib/libgtk-x11-2.0.so.0
#7  0x004ca9ef in gtk_file_chooser_get_current_folder ()
   from /usr/lib/libgtk-x11-2.0.so.0
#8  0x004caff3 in gtk_file_chooser_set_current_folder_uri ()
   from /usr/lib/libgtk-x11-2.0.so.0
#9  0x08074395 in rb_ask_file_internal (title=Variable "title" is not available.
) at rb-dialog.c:130
#10 0x08062fa2 in rb_shell_cmd_add_to_library (component=0x8a5a6c8,
    shell=0x8a04660, verbname=0x8c36a28 "AddToLibrary") at rb-shell.c:2338
#11 0x03284165 in bonobo_socket_add_id () from /usr/lib/libbonoboui-2.so.0
#12 0x00138b98 in IA__g_closure_invoke (closure=0x8a70940,
    return_value=0xbffb3cf4, n_param_values=2, param_values=0x8c515e0,
---Type <return> to continue, or q <return> to quit---
    invocation_hint=0x0) at gclosure.c:492
#13 0x0321d696 in bonobo_closure_invoke_va_list (closure=0x8a70940,
    return_value=0x8c85866, var_args=0x0) at bonobo-types.c:415
#14 0x0321d984 in bonobo_closure_invoke (closure=0x8a70940, return_type=4)
    at bonobo-types.c:478
#15 0x0328663c in bonobo_ui_component_remove_listener ()
   from /usr/lib/libbonoboui-2.so.0
#16 0x0321e6b7 in _ORBIT_skel_small_Bonobo_UIComponent_execVerb (
    _o_servant=0x8c85866, _o_retval=0x0, _o_args=0x8c85866, _o_ctx=0x0,
    _o_ev=0x8c85866,
    _impl_execVerb=0x32865a2 <bonobo_ui_component_remove_listener+216>)
    at Bonobo-common.c:332
#17 0x0300c8bd in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#18 0x03222316 in Bonobo_UIComponent_execVerb (_obj=0x8c85866,
    cname=0x8ba8910 "AddToLibrary", ev=0x8c85866) at Bonobo-stubs.c:544
#19 0x0328aa88 in bonobo_ui_engine_ui_event () from /usr/lib/libbonoboui-2.so.0
#20 0x00144bce in IA__g_cclosure_marshal_VOID__POINTER (closure=0x8a540b0,
    return_value=0x0, n_param_values=2, param_values=0xbffb411c,
    invocation_hint=0xbffb401c, marshal_data=0x328a8d3) at gmarshal.c:601
#21 0x00138565 in g_type_class_meta_marshal (closure=0x8a540b0,
    return_value=0x0, n_param_values=2, param_values=0xbffb411c,
    invocation_hint=0xbffb401c, marshal_data=0x4c) at gclosure.c:569
#22 0x00138b98 in IA__g_closure_invoke (closure=0x8a540b0, return_value=0x0,
---Type <return> to continue, or q <return> to quit---
    n_param_values=2, param_values=0xbffb411c, invocation_hint=0xbffb401c)
    at gclosure.c:492
#23 0x0014736f in signal_emit_unlocked_R (node=0x8a54110, detail=0,
    instance=0x8a55a28, emission_return=0x0, instance_and_params=0xbffb411c)
    at gsignal.c:2523
#24 0x00148820 in IA__g_signal_emit_valist (instance=0x8a55a28, signal_id=121,
    detail=0, var_args=Variable "var_args" is not available.
) at gsignal.c:2244
#25 0x00148b93 in IA__g_signal_emit (instance=0x8a55a28, signal_id=121,
    detail=0) at gsignal.c:2288
#26 0x0328a2ad in bonobo_ui_engine_emit_verb_on_w ()
   from /usr/lib/libbonoboui-2.so.0
#27 0x03290736 in bonobo_ui_sync_wrap_widget ()
   from /usr/lib/libbonoboui-2.so.0
#28 0x001442d3 in IA__g_cclosure_marshal_VOID__VOID (closure=0x8a8fdb8,
    return_value=0x0, n_param_values=1, param_values=0xbffb45bc,
    invocation_hint=0xbffb44bc, marshal_data=0x3290701) at gmarshal.c:77
#29 0x00138b98 in IA__g_closure_invoke (closure=0x8a8fdb8, return_value=0x0,
    n_param_values=1, param_values=0xbffb45bc, invocation_hint=0xbffb44bc)
    at gclosure.c:492
#30 0x001471e3 in signal_emit_unlocked_R (node=0x8ac3e90, detail=0,
    instance=0x8ac69d8, emission_return=0x0, instance_and_params=0xbffb45bc)
    at gsignal.c:2485
#31 0x00148820 in IA__g_signal_emit_valist (instance=0x8ac69d8, signal_id=316,
---Type <return> to continue, or q <return> to quit---
    detail=0, var_args=Variable "var_args" is not available.
) at gsignal.c:2244
#32 0x00148b93 in IA__g_signal_emit (instance=0x8ac69d8, signal_id=316,
    detail=0) at gsignal.c:2288
#33 0x00631e0b in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#34 0x0054a810 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#35 0x0054ab17 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#36 0x0053f05b in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#37 0x005388bc in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#38 0x00138565 in g_type_class_meta_marshal (closure=0x8a3d4c0,
    return_value=0xbffb49f0, n_param_values=2, param_values=0xbffb4adc,
    invocation_hint=0xbffb49dc, marshal_data=0xb4) at gclosure.c:569
#39 0x00138b98 in IA__g_closure_invoke (closure=0x8a3d4c0,
    return_value=0xbffb49f0, n_param_values=2, param_values=0xbffb4adc,
    invocation_hint=0xbffb49dc) at gclosure.c:492
#40 0x0014736f in signal_emit_unlocked_R (node=0x8a3d518, detail=0,
    instance=0x8ac4910, emission_return=0xbffb4c5c,
    instance_and_params=0xbffb4adc) at gsignal.c:2523
#41 0x00148593 in IA__g_signal_emit_valist (instance=0x8ac4910, signal_id=66,
    detail=0, var_args=0xbffb4ce0 "\uffffL\uffff\uffff
\uffff\uffff\b\020I\uffff\b\215\"c") at gsignal.c:2254
#42 0x00148b93 in IA__g_signal_emit (instance=0x8ac4910, signal_id=66,
---Type <return> to continue, or q <return> to quit---
    detail=0) at gsignal.c:2288
#43 0x00632059 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#44 0x00535a13 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#45 0x00535f3d in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#46 0x008bb95f in gdk_screen_get_setting () from /usr/lib/libgdk-x11-2.0.so.0
#47 0x007aa9ce in IA__g_main_context_dispatch (context=0x89f63c0)
    at gmain.c:1934
#48 0x007ad9e6 in g_main_context_iterate (context=0x89f63c0, block=1,
    dispatch=1, self=0x8932e70) at gmain.c:2565
#49 0x007adcd3 in IA__g_main_loop_run (loop=0x8a04460) at gmain.c:2769
#50 0x0320b660 in bonobo_main () at bonobo-main.c:297
#51 0x0805fd7d in main (argc=1, argv=0xbffb5234) at main.c:202
Comment 1 Caolan McNamara 2005-08-17 04:45:23 EDT
this is possibly bug 165712
Comment 2 John Thacker 2006-04-29 09:50:19 EDT
Can you still duplicate this with your system updated 
(at least to gtk2 2.8.x, since this be bug 165712?)
Comment 3 James Laska 2006-05-01 08:37:00 EDT
No longer hitting this problem using rhythmbox-0.9.4.1-2.i386 while importing a
folder backed by gnome-vfs (sftp) with > 5000 songs.
Comment 4 John Thacker 2006-05-01 09:09:30 EDT
Ok, great!  Closing.

Note You need to log in before you can comment on or make changes to this bug.