Bug 1659853 - Can not order all fields in the bug list page sometimes
Summary: Can not order all fields in the bug list page sometimes
Keywords:
Status: CLOSED DUPLICATE of bug 1658598
Alias: None
Product: Bugzilla
Classification: Community
Component: Query/Bug List
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 02:59 UTC by Rony Gong 🔥
Modified: 2018-12-17 06:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-17 06:50:35 UTC


Attachments (Terms of Use)

Description Rony Gong 🔥 2018-12-17 02:59:26 UTC
Description of problem:
Can not order all fields in the bug list page sometimes

Version-Release number of selected component (if applicable):
5.0.4.rh11
Browser: chrome 68

How reproducible:
Sometimes

Steps to Reproduce:
1.Log in, then click the link 'My Bugs'
2.If the list can be ordered, then try many times of resetting it to Bugzilla default fields
3.

Actual results:
Can't sort this list by any fields

Expected results:
Can sore this list by any fields

Additional info:
The exception in the chrome console:
datatables.min.js:77 Uncaught TypeError: Cannot read property 'aDataSort' of undefined
    at W (datatables.min.js:77)
    at xa (datatables.min.js:81)
    at HTMLTableElement.<anonymous> (datatables.min.js:105)
    at Function.each (jquery-1.7.1.min.js:2)
    at init.each (jquery-1.7.1.min.js:2)
    at init.m [as dataTable] (datatables.min.js:97)
    at init.h.fn.DataTable (datatables.min.js:176)
    at HTMLDocument.<anonymous> (VM2052 buglist.cgi:9865)
    at n (jquery-1.7.1.min.js:2)
    at Object.fireWith (jquery-1.7.1.min.js:2)

Comment 1 Jeff Fearn 🐞 2018-12-17 06:50:35 UTC

*** This bug has been marked as a duplicate of bug 1658598 ***


Note You need to log in before you can comment on or make changes to this bug.