Bug 1658598 - Changing multiple bugs at once does not work
Summary: Changing multiple bugs at once does not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 5.0-RH2
Assignee: Jeff Fearn 🐞
QA Contact: Rony Gong 🔥
URL:
Whiteboard:
: 1658703 1659853 1664282 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-12 13:48 UTC by Jaroslav Suchanek
Modified: 2019-04-04 10:36 UTC (History)
8 users (show)

Fixed In Version: 5.0.4.rh13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 02:13:42 UTC


Attachments (Terms of Use)
Screenshot of buglist (220.16 KB, image/png)
2018-12-12 14:49 UTC, Jaroslav Suchanek
no flags Details
qe_ff64_on_fedora28 (286.86 KB, image/png)
2018-12-13 04:59 UTC, Rony Gong 🔥
no flags Details

Description Jaroslav Suchanek 2018-12-12 13:48:45 UTC
Description of problem:

It is not possible to change multiple bugs at once. There is no column with checkboxes for bugs selection.

I tried to apply it to the query result product = 'Red Han Enterprise Linux 8', component = 'libvirt', summary contains 'Fast Train'.

Additional info:

Browser is Firefox 64.0 for Linux.

Comment 1 Rony Gong 🔥 2018-12-12 14:05:22 UTC
(In reply to Jaroslav Suchanek from comment #0)
> Description of problem:
> 
> It is not possible to change multiple bugs at once. There is no column with
> checkboxes for bugs selection.
> 
> I tried to apply it to the query result product = 'Red Han Enterprise Linux
> 8', component = 'libvirt', summary contains 'Fast Train'.
> 
> Additional info:
> 
> Browser is Firefox 64.0 for Linux.

Actually, there are buttons 'select all' and 'deselect all' that used to select/deselect all bugs.
Also, you can click one bug to select/deselect it. Please have a try again.

Comment 2 Jaroslav Suchanek 2018-12-12 14:49:43 UTC
Created attachment 1513692 [details]
Screenshot of buglist

Screenshot of bugs wchich should be changed at once. I am missing a control, either button or checklist which I can use for selection.

Comment 3 Jaroslav Suchanek 2018-12-12 14:51:22 UTC
I have checked it once more. No such buttons are presented as suggested in comment 1. Thanks.

Comment 4 Jeff Fearn 🐞 2018-12-12 22:28:00 UTC
The javascript that adds the buttons get's fired after the table has completed loading, it might be a problem with FF64, I've only got FF63 on F29. Rony can you get FF64 and test please?

Comment 5 Jeff Fearn 🐞 2018-12-12 22:47:35 UTC
*** Bug 1658703 has been marked as a duplicate of this bug. ***

Comment 6 James Smith 2018-12-13 04:31:50 UTC
Jeff, I get the same problem in FF64 on RHEL 7.4.

Also same on Chrome.

James

Comment 7 Rony Gong 🔥 2018-12-13 04:58:13 UTC
(In reply to Jeff Fearn from comment #4)
> The javascript that adds the buttons get's fired after the table has
> completed loading, it might be a problem with FF64, I've only got FF63 on
> F29. Rony can you get FF64 and test please?

It works well in my firefox 64 which based on fedora28, I just download the firefox tar file and unzip it and start it.
You can check the attachment

Comment 8 Rony Gong 🔥 2018-12-13 04:59:22 UTC
Created attachment 1513871 [details]
qe_ff64_on_fedora28

Comment 9 Jeff Fearn 🐞 2018-12-13 05:09:01 UTC
OK I have tracked this down, it's not about multiple edit or not, it's about field ordering in the search. If the search, saved or otherwise, is sorting by multiple columns, and any except the last search field is ascending, then it will generate a javascript error and prevent the table from fully loading.

The work around is to edit the search and change "Sort results by" to a single field, run the search, and everything should work.


e.g. The generated JS:

order: [[7,  'asc'][4,  'asc'], 

Vs:

order: [[1,  'desc'], [8,  'desc'],

Comment 10 Jeff Fearn 🐞 2018-12-17 06:50:35 UTC
*** Bug 1659853 has been marked as a duplicate of this bug. ***

Comment 11 Jeff Fearn 🐞 2018-12-18 02:31:34 UTC
hmm the search I had that was duplicating this no longer triggers this, does anyone have a search that still triggers this or a way of reliably reproducing it?

Comment 12 Jeff Fearn 🐞 2018-12-18 03:11:50 UTC
OK, this search works to reproduce:

https://bugzilla.redhat.com/buglist.cgi?columnlist=bug_status%2Cassigned_to%2Cqa_contact%2Ctarget_milestone%2Ccf_devel_whiteboard%2Cproduct%2Ccomponent&component=libvirt&product=Red%20Hat%20Enterprise%20Linux%208&query_format=advanced&order=component,bug_status

The trigger is filtering by the last column in the table before another column.

e.g. in the search provided component is the last field displayed and is ordered before bug_status.

For some reason FireFox seems to tolerate the missing comma, but you can show the page source and search for '#bz_buglist' and you can see the missing comma in the order array.

Workaround is to not order by the last column, or to order by that column last.

Comment 13 Luke Meyer 2018-12-21 15:31:20 UTC
It seems to be broken only if I sort by the last column (Changed) on the search, and then try to change multiple. Sorting once the bug list is loaded doesn't break it. Thanks for looking at this.

Comment 15 Rony Gong 🔥 2019-01-10 06:51:54 UTC
Verified on commit: f6835a7f9
PASS

Comment 16 Jeff Fearn 🐞 2019-01-13 23:42:07 UTC
*** Bug 1664282 has been marked as a duplicate of this bug. ***

Comment 17 Jeff Fearn 🐞 2019-02-06 07:11:25 UTC
This change has been deployed to partner Bugzilla [1] for pre-release testing, if your testing reveals any issues please update this bug.

1: https://partner-bugzilla.redhat.com/

Comment 18 Jeff Fearn 🐞 2019-02-13 02:13:42 UTC
This change is now live. If there are any issues, do not reopen this bug.                                                                                                           
Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.