Bug 166018 - Missing entry in pcitable from package hwdata
Missing entry in pcitable from package hwdata
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Fabio Olive Leite
:
: 163353 (view as bug list)
Depends On:
Blocks: 166499
  Show dependency treegraph
 
Reported: 2005-08-15 16:06 EDT by brian
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 16:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brian 2005-08-15 16:06:14 EDT
We are working on using the system-config-netboot tool that is part of the
RedHat 3 & 4 AS releases.  In using this tool, actually the updated one from:
http://people.redhat.com/~jvdias/system-config-netboot/, as part of the diskless
boot it executes a function that does an lspci to establish what devices the
system has so that it can figure which ones are ethernet devices to load the
right driver.  The problem I'm having is that it is working for most all of my
systems except a couple and the problem appears to be that
/usr/share/hwdata/pcitable as part of the hwdata rpm is incomplete for this device.

The hardware I have is the Arima HDAMA motherboard which has two broadcom gigE
NICs onboard.  For most all of the systems I have the info that lspci gives for
the ethernet devices is this:

lspci -n |grep "Class 0200"
02:03.0 Class 0200: 14e4:16a6 (rev 02)
02:04.0 Class 0200: 14e4:16a6 (rev 02)


Those listed above work just fine and end up allowing the script to find and
load the tg3 driver.  However on a few boards the output is this:

lspci -n |grep "Class 0200"
02:03.0 Class 0200: 14e4:1653 (rev 03)
02:04.0 Class 0200: 14e4:1653 (rev 03)

the /usr/share/hwdata/pcitable file does not have an entry with 1653 in it for
the tg3 driver and thus the rest of the disklessrc script from
system-config-netboot is unable to find the right driver and it exits incomplete.

This simply seems to be then a request to have the additional info added to
pcitable such that:

lspci -n |grep "Class 0200"
02:03.0 Class 0200: 14e4:1653 (rev 03)
02:04.0 Class 0200: 14e4:1653 (rev 03)

results in a positive match to the tg3 driver.  Thanks.
Comment 1 Bill Nottingham 2005-08-19 03:16:07 EDT
pcitable entries aren't needed, as that device is supported in the module's own
pci id tables. system-config-netboot can't just be grepping pcitable.
Comment 2 Jason Vas Dias 2005-08-19 16:39:24 EDT
This is now fixed with system-config-netboot-0.1.30-1 .
disklessrc should have been looking in the modules.pcimap file generated by
depmod, not in the hwdata pcitable. It should find the tg3 driver for your
14e4:1653 devices correctly now.
0.1.30-1 can be downloaded from:
   http://people.redhat.com/~jvdias/system-config-netboot/
This version also fixes other bugs - 
eg.: bug 166217, 165735 , bug 165772, bug 165730.
Please try out this version and let me know of any issues - thank you.
Comment 4 Bill Nottingham 2005-09-14 10:14:25 EDT
*** Bug 163353 has been marked as a duplicate of this bug. ***
Comment 7 RHEL Product and Program Management 2006-09-05 15:50:10 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 8 RHEL Product and Program Management 2006-09-05 16:03:01 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.