Bug 166499 - Missing entry in pcitable from package hwdata
Missing entry in pcitable from package hwdata
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-netboot (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Fabio Olive Leite
:
Depends On: 166018
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-22 11:48 EDT by Jason Vas Dias
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 0.1.30-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 11:40:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2005-08-22 11:48:16 EDT
+++ This bug was initially created as a clone of Bug #166018 +++

We are working on using the system-config-netboot tool that is part of the
RedHat 3 & 4 AS releases.  In using this tool, actually the updated one from:
http://people.redhat.com/~jvdias/system-config-netboot/, as part of the diskless
boot it executes a function that does an lspci to establish what devices the
system has so that it can figure which ones are ethernet devices to load the
right driver.  The problem I'm having is that it is working for most all of my
systems except a couple and the problem appears to be that
/usr/share/hwdata/pcitable as part of the hwdata rpm is incomplete for this device.

The hardware I have is the Arima HDAMA motherboard which has two broadcom gigE
NICs onboard.  For most all of the systems I have the info that lspci gives for
the ethernet devices is this:

lspci -n |grep "Class 0200"
02:03.0 Class 0200: 14e4:16a6 (rev 02)
02:04.0 Class 0200: 14e4:16a6 (rev 02)


Those listed above work just fine and end up allowing the script to find and
load the tg3 driver.  However on a few boards the output is this:

lspci -n |grep "Class 0200"
02:03.0 Class 0200: 14e4:1653 (rev 03)
02:04.0 Class 0200: 14e4:1653 (rev 03)

the /usr/share/hwdata/pcitable file does not have an entry with 1653 in it for
the tg3 driver and thus the rest of the disklessrc script from
system-config-netboot is unable to find the right driver and it exits incomplete.

This simply seems to be then a request to have the additional info added to
pcitable such that:

lspci -n |grep "Class 0200"
02:03.0 Class 0200: 14e4:1653 (rev 03)
02:04.0 Class 0200: 14e4:1653 (rev 03)

results in a positive match to the tg3 driver.  Thanks.
Comment 1 Jason Vas Dias 2005-08-22 11:51:24 EDT
This is now fixed with redhat-config-netboot-0.1.26-1 
Comment 2 Jason Vas Dias 2005-08-22 11:59:49 EDT
Sorry, the above version should have been redhat-config-netboot-0.1.28-1

Note You need to log in before you can comment on or make changes to this bug.