Bug 1660227 - XML-RPC response too large.
Summary: XML-RPC response too large.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreport
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matej Marušák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1662919 1671499 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-17 21:52 UTC by Marek Pikuła
Modified: 2019-02-09 02:13 UTC (History)
9 users (show)

Fixed In Version: libreport-2.10.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-09 02:13:19 UTC


Attachments (Terms of Use)

Description Marek Pikuła 2018-12-17 21:52:19 UTC
The same bug as 961520 and 814628 and 666893.

Tried to post a bug report about Inkscape.

My error message: "fatal: Unable to make sense of XML-RPC response from server.  XML-RPC response too large.  Our limit is 4194304 characters.  We got 5137653 characters.  Use XMLRPC_TRACE_XML to see for yourself"

Comment 1 Matej Marušák 2019-01-09 14:08:59 UTC
*** Bug 1662919 has been marked as a duplicate of this bug. ***

Comment 2 Matej Marušák 2019-01-10 13:22:38 UTC
Following test is mostly for ABRT developers:
In `src/lib/abrt_xmlrpc.c` we set `xmlrpc_limit_set(XMLRPC_XML_SIZE_LIMIT_ID, 8 * XMLRPC_XML_SIZE_LIMIT_DEFAULT);` which directly affects size, we can process. It has been updated before when similar bugzillas were open. We could do that again to fit limit as seen in #1662919, but it is not really a solution as one day someone can come with even bigger needs.

Digging deeper, it happens when we query bugs and there are way to many corresponding bugs to our query (and/or data of those bugs are too big). It means, for example, that when we look for all bugs with specific abrt_hash (`rhbz_search_duphash()`) a lot of bugs with a lot of information are returned. Main problem, as I see it, is that we don't really need all fields of all bugs (like text, list of attachements, CC contacts etc.). We need only a few simple ones. If we would be able to get only specified fields of corresponding bugs, we can easily fit all bugs on Bugzilla in the limit we have.
Bugzilla provides `include_fields` option when downloading specific bugs, but it seems it does not work with searching (#1665064).

Comment 3 Matej Marušák 2019-01-14 11:06:25 UTC
Upstream PR https://github.com/abrt/libreport/pull/550

Comment 4 Martin Kutlak 2019-02-01 08:38:39 UTC
*** Bug 1671499 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2019-02-04 13:18:17 UTC
libreport-2.10.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-173faa3148

Comment 6 Fedora Update System 2019-02-05 04:05:40 UTC
libreport-2.10.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-173faa3148

Comment 7 Fedora Update System 2019-02-09 02:13:19 UTC
libreport-2.10.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.