Bug 166026 - can select drivers that aren't intsalled
can select drivers that aren't intsalled
Status: CLOSED DUPLICATE of bug 212139
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 18:19 EDT by Bill Nottingham
Modified: 2014-03-16 22:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-13 12:51:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-08-15 18:19:36 EDT
Description of problem:

I set up a SMB print queue to a HP 2410 printer. It said it was going to use the
hpijs driver.

Printing failed without any errors presented to the user. After looking in
the logs, and seeing:

D [15/Aug/2005:18:08:38 -0400] [Job 1] sh: hpijs: command not found
D [15/Aug/2005:18:08:38 -0400] [Job 1] ESP Ghostscript 815.00: Can't start ijs
server "hpijs"
D [15/Aug/2005:18:08:38 -0400] [Job 1] **** Unable to open the initial device,
quitting.

I decided to actually install hpijs. Worked much better then. :)

Version-Release number of selected component (if applicable):

hpijs-0.9.4-3
system-config-printer-0.6.141-1
foomatic-3.0.2-24

Additional info:

Can possibly just be chalked up to user error; not sure what the graceful way to
handle this without installing hpijs on every box with foomatic is.
Comment 1 Tim Waugh 2005-08-16 04:40:12 EDT
Fixed in CVS.
Comment 2 John Thacker 2007-01-13 12:51:44 EST
Sounds like this was fixed in the 0.6.x series, then cropped back up in 0.7.x
(see bug 212139)  In any case, it's fixed on both 0.6.x (up to FC5) and 0.7.x
(FC6+) now.

*** This bug has been marked as a duplicate of 212139 ***

Note You need to log in before you can comment on or make changes to this bug.