Bug 212139 - system-config-printer should check drivers are installed
Summary: system-config-printer should check drivers are installed
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
: 166026 212765 (view as bug list)
Depends On:
Blocks: FC6Update 212533
TreeView+ depends on / blocked
 
Reported: 2006-10-25 09:40 UTC by Thomas Canniot
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 0.7.35-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 17:13:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups error log (26.12 KB, text/plain)
2006-10-25 09:40 UTC, Thomas Canniot
no flags Details
cups error_log (103.68 KB, text/plain)
2006-10-25 16:50 UTC, Thomas Canniot
no flags Details

Description Thomas Canniot 2006-10-25 09:40:22 UTC
Description of problem:
Nothing can be printed with an HP 3320 on FC6.

Version-Release number of selected component (if applicable):
The version of cups and system-config-printer released by default.

How reproducible:
Everytime

Steps to Reproduce:
1. Open system-config-printer
2. Try to impress a test page

  
Actual printer :
Nothing comes out from the printer 

Expected results:
Should print the test page at least 

Additional info : cups error log attached

Comment 1 Thomas Canniot 2006-10-25 09:40:22 UTC
Created attachment 139323 [details]
cups error log

Comment 2 Tim Waugh 2006-10-25 09:52:26 UTC
Released versions are:

cups-1.2.4-9
system-config-printer-0.7.32-1

Thanks for the bug report.  I need some more information in order to diagnose
the problem.

1. Please show me what 'ls -l /etc/cups/' says.
2. Was this a fresh install or an upgrade?
3. I'd like to see an error_log file with full debugging turned on.  To get
this, become root with 'su -' and then stop cups:

  /sbin/service cups stop

Clear out the error_log file:

  >/var/log/cups/error_log

Edit /etc/cups/cupsd.conf and change the 'LogLevel' line to read 'LogLevel
debug2'.  Then restart cups:

  /sbin/service cups start

Try submitting a test page again, and then please attach the error_log file to
this bug report.  Thanks.

Comment 3 Thomas Canniot 2006-10-25 16:50:55 UTC
Created attachment 139366 [details]
cups error_log

Comment 4 Thomas Canniot 2006-10-25 16:52:10 UTC
1. Please show me what 'ls -l /etc/cups/' says.

[mrtom@localhost ~]$ ls -l /etc/cups/
total 120
-rw------- 1 root lp     82 oct 25 10:40 classes.conf
-rw------- 1 root lp      0 oct  5 17:43 classes.conf.O
-rw-r--r-- 1 root lp      0 oct  5 17:43 client.conf
-rw-r----- 1 root lp   2472 oct  5 17:43 cupsd.conf
-rw-r----- 1 root lp   2472 oct  5 17:43 cupsd.conf.default
drwxr-xr-x 2 root root 4096 oct  5 17:43 interfaces
-rw-r--r-- 1 root root 4579 oct  5 17:43 mime.convs
-rw-r--r-- 1 root root 6223 oct  5 17:43 mime.types
-rw-r--r-- 1 root lp    239 oct  5 17:43 pdftops.conf
drwxr-xr-x 2 root lp   4096 oct 25 18:18 ppd
-rw------- 1 root lp    930 oct 25 18:36 printers.conf
-rw------- 1 root lp    929 oct 25 18:36 printers.conf.O
-rw-r--r-- 1 root root  947 oct  5 17:43 pstoraster.convs
-rw-r--r-- 1 root lp     69 oct  5 17:43 snmp.conf
drwx------ 2 root lp   4096 oct  5 17:43 ssl

2. Was this a fresh install or an upgrade?

A fresh install

3. I'd like to see an error_log file with full debugging turned on.

See attached file above.

Comment 5 Tim Waugh 2006-10-26 11:49:55 UTC
D [25/Oct/2006:18:39:56 +0200] [Job 4] sh: hpijs: command not found

Okay, the problem is that the hpijs package isn't installed.  You can install it
yourself, but a better fix would be for system-config-printer to do this when
necessary.

As a workaround, 'yum install hpijs' should make things work.

Comment 6 Thomas Canniot 2006-10-26 19:21:05 UTC
Thanks. I installed it but had no time to test it.

The fact is that I chose not to install everything containing *sane* in my FC6
fresh install, as I don't have any scanner. Maybe a kind of abusive dependency ?

Comment 7 Tim Waugh 2006-10-27 09:43:42 UTC
Ah, yes, there is an unintentional dependency there -- I've just filed bug
#212531 to track that.


Comment 8 Tim Waugh 2006-10-31 10:25:11 UTC
*** Bug 212765 has been marked as a duplicate of this bug. ***

Comment 9 Tim Waugh 2006-10-31 10:25:41 UTC
pnm2ppa is another instance of this.

Comment 10 Tim Waugh 2006-11-01 13:30:59 UTC
Code checked into CVS.  No translations for the new messages yet.

Comment 11 Thomas Canniot 2006-11-01 13:56:24 UTC
Done for French.

Comment 12 Thomas Canniot 2006-11-05 17:57:42 UTC
OK it works well with hpijs installed thanks.

Comment 13 Fedora Update System 2006-11-09 17:02:24 UTC
Fixed in update: system-config-printer-0.7.35-1.fc6

Comment 14 John Thacker 2007-01-13 17:52:01 UTC
*** Bug 166026 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.