Bug 1660759 - strace prints "xlat_idx: Unexpected xlat value 0 at index 4" messages
Summary: strace prints "xlat_idx: Unexpected xlat value 0 at index 4" messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: strace
Version: 8.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: 8.0
Assignee: Eugene Syromiatnikov
QA Contact: Edjunior Barbosa Machado
URL:
Whiteboard:
Depends On: 1682600
Blocks: 1696304
TreeView+ depends on / blocked
 
Reported: 2018-12-19 07:45 UTC by Renaud Métrich
Modified: 2019-11-05 22:33 UTC (History)
4 users (show)

Fixed In Version: strace-4.24-4.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1666405 (view as bug list)
Environment:
Last Closed: 2019-11-05 22:33:07 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3642 None None None 2019-11-05 22:33:14 UTC

Description Renaud Métrich 2018-12-19 07:45:15 UTC
Description of problem:

When stracing systemd (PID 1), I can see the following message:

# strace -fttTvyy -o systemd.strace -s 1024 -p 1
strace: Process 1 attached
...
strace: xlat_idx: Unexpected xlat value 0 at index 4


Version-Release number of selected component (if applicable):

strace-4.24-2.el8.x86_64


How reproducible:

Always


Steps to Reproduce:
1. strace systemd

  # strace -fttTvyy -o systemd.strace -s 1024 -p 1

2. restart systemd-logind

  # systemctl restart systemd-logind.service

Actual results:

strace: Process 1 attached
strace: Process 1901 attached
strace: xlat_idx: Unexpected xlat value 0 at index 4

Expected results:

strace: Process 1 attached
strace: Process 1901 attached

Comment 1 Eugene Syromiatnikov 2019-01-15 15:24:14 UTC
Fixed in upstream:
https://gitlab.com/strace/strace/commit/8a5feb1cb331441d1b721b6455ee95b50258dbac "evdev: fix off-by-one error in decode_bitset"

Related commits:
https://gitlab.com/strace/strace/commit/b2c63fa8973442747de715ff5ff5340383e7b69d "nlattr: fix off-by-one error in indexed xlat lookup"
https://gitlab.com/strace/strace/commit/986a55423eb8e16a7cd0b249ce8e18465f0650f4 "aio: fix off-by-one error in indexed xlat lookup"
https://gitlab.com/strace/strace/commit/d0ae0b3dcabfd61dd2134422114570862fdca283 "rtnl_link: fix off-by-one errors in indexed and sorted xlat lookups"
https://gitlab.com/strace/strace/commit/b967e34d70895b799d16f5d45a9a5228d7eb73a3 "xlat_idx: do not issue warnings for holes in indices"
https://gitlab.com/strace/strace/commit/99300f217b7870fcaa752e1350a33cf98d61a993 "evdev: fix decoding of bit sets"
https://gitlab.com/strace/strace/commit/5ee385e2eb9288ae49e07dca67e576abb2e10fea "evdev: fix decoding of EVIOCGBIT(0, ...)"

Comment 5 errata-xmlrpc 2019-11-05 22:33:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3642


Note You need to log in before you can comment on or make changes to this bug.