Bug 1660772 - new kernel is not loading
Summary: new kernel is not loading
Keywords:
Status: CLOSED DUPLICATE of bug 1659810
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-19 08:12 UTC by tothaa
Modified: 2019-01-07 20:03 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-07 20:03:23 UTC


Attachments (Terms of Use)
/var/log/messages (493.56 KB, text/plain)
2018-12-19 08:12 UTC, tothaa
no flags Details
log when failure with new kernel (199.06 KB, text/plain)
2018-12-20 00:09 UTC, tothaa
no flags Details
log when good with old kernel (230.22 KB, text/plain)
2018-12-20 00:09 UTC, tothaa
no flags Details

Description tothaa 2018-12-19 08:12:22 UTC
Created attachment 1515511 [details]
/var/log/messages

Description of problem:
While 0.rc5.git3.1.vanilla.knurd.1.fc29 is working correctly, with the later kernel versions (rc6, rc7...) I experience the issue.

It shows a splash screen with ASUS logo after the kernel is selected in GRUB2; and nothing else happens.

Version-Release number of selected component (if applicable):
0.rc6.git01.vanilla.knurd.1.fc29 and above

How reproducible:
boot the computer

Steps to Reproduce:
boot my computer

Actual results:
stops boot with a splash screen.

Expected results:
after the splash screen it should display the login screen.

Additional info:
please, advice what log to include here.... I am attaching my /var/log/messages

Comment 1 Steve 2018-12-19 08:56:00 UTC
> Dec 19 08:46:47 localhost kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-4.20.0-0.rc5.git3.1.vanilla.knurd.1.fc29.x86_64 root=UUID=532c1a72-d32a-4bca-a06c-199eb6bd3c3b ro rhgb quiet LANG=hu_HU.UTF-8

Try removing "rhgb quiet" from the kernel command-line:

Method 1: Edit the kernel command-line from grub.

Method 2: Edit /etc/default/grub and then run:
# grub2-mkconfig -o /boot/grub2/grub.cfg  # it is a good idea to make a backup copy of grub.cfg first

> Dec 19 07:58:04 localhost dnf[2590]: RPM Fusion for Fedora 29 - Free - Updates       7.6 kB/s | 8.9 kB     00:01

Also, please remove any RPM Fusion packages before testing, so you are only reporting bugs against Fedora packages.

> please, advice what log to include here.... I am attaching my /var/log/messages

$ journalctl -b # log for current boot
$ journalctl -b -1 # log for previous boot

Documentation:

$ info grub2
$ man journalctl

Comment 2 Steve 2018-12-19 09:19:02 UTC
> Dec 19 07:46:51 localhost kernel: Generic PHY r8169-600:00: attached PHY driver [Generic PHY] (mii_bus:phy_addr=r8169-600:00, irq=IGNORE)

> Dec 19 08:46:16 localhost kernel: smpboot: CPU0: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz (family: 0x6, model: 0x5e, stepping: 0x3)

The Intel i7-6700K is a Skylake processor. If you are getting a boot hang, you could be seeing:

Bug 1660649 - r8169: hang or reboot when networking is enabled with kernel 4.19.9 on Intel Skylake system 

See if you can reproduce the hang using the method described in that bug report.

Comment 3 tothaa 2018-12-20 00:08:07 UTC
Thank you for your quick reply.

@ I am following advices from "2018-12-19 08:56:00 UTC":


> cp /boot/efi/EFI/fedora/grub.cfg /boot/efi/EFI/fedora/grub.cfg_my_orig
> sudo featherpad /etc/default/grub    # commented out the options
> sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Reboot...
Now I see the messages :-) Thanks for the tips!

This is the last message, then loading stops:

    dec 20 01:19:57 localhost.localdomain kernel: fb0: switching to amdgpudrmfb from EFI VGA

    
Then I pressed CTRL+ALT+DEL to restart.


So I am attaching the logs here now:
> sudo journalctl -b -1 > /home/andrew/Letöltések/msgs_fail.txt
> sudo journalctl -b > /home/andrew/Letöltések/msgs_goodload.txt


But I found "amdgpu 0000:01:00.0: Fatal error during GPU init" in the log :S






Fusion should not had affected the boot...
> yum list installed | grep fusion
compat-ffmpeg28.x86_64                           2.8.15-2.fc29                            @rpmfusion-free           
faac.x86_64                                      1.29.9.2-4.fc29                          @rpmfusion-nonfree        
faad2-libs.x86_64                                1:2.8.8-2.fc29                           @rpmfusion-free           
fdk-aac.x86_64                                   0.1.6-3.fc29                             @rpmfusion-nonfree        
ffmpeg.x86_64                                    4.0.3-1.fc29                             @rpmfusion-free-updates   
ffmpeg-libs.x86_64                               4.0.3-1.fc29                             @rpmfusion-free-updates   
ffmpegthumbs.x86_64                              18.08.1-1.fc29                           @rpmfusion-free           
gstreamer1-plugins-bad-freeworld.x86_64          1.14.4-1.fc29                            @rpmfusion-free           
gstreamer1-plugins-bad-nonfree.x86_64            1.14.4-1.fc29                            @rpmfusion-nonfree        
gstreamer1-plugins-ugly.x86_64                   1.14.4-2.fc29                            @rpmfusion-free-updates   
libavdevice.x86_64                               4.0.3-1.fc29                             @rpmfusion-free-updates   
libdca.x86_64                                    0.0.6-2.fc29                             @rpmfusion-free           
libde265.x86_64                                  1.0.3-2.fc29                             @rpmfusion-free           
libmms.x86_64                                    0.6.4-7.fc29                             @rpmfusion-free           
libmpeg2.x86_64                                  0.5.1-16.fc29                            @rpmfusion-free           
librtmp.x86_64                                   2.4-12.20160224.gitfa8646d.fc29          @rpmfusion-free           
live555.x86_64                                   2018.10.17-1.fc29                        @rpmfusion-free           
mjpegtools-libs.x86_64                           2.1.0-13.fc29                            @rpmfusion-free           
opencore-amr.x86_64                              0.1.5-5.fc29                             @rpmfusion-free           
python3-vlc.noarch                               1.1.2-8.20161001git5d389c7.fc29          @rpmfusion-free           
rpmfusion-free-appstream-data.noarch             29-4.20181021.fc29                       @rpmfusion-free           
rpmfusion-free-release.noarch                    29-1                                     @rpmfusion-free-updates   
rpmfusion-nonfree-appstream-data.noarch          29-3.20181021.fc29                       @rpmfusion-nonfree        
rpmfusion-nonfree-release.noarch                 29-1                                     @rpmfusion-nonfree-updates
vcdimager.x86_64                                 2.0.1-4.fc29                             @rpmfusion-free           
vcdimager-libs.x86_64                            2.0.1-4.fc29                             @rpmfusion-free           
vlc.x86_64                                       3.0.5-4.fc29                             @rpmfusion-free           
vlc-core.x86_64                                  3.0.5-4.fc29                             @rpmfusion-free           
vlc-extras.x86_64                                3.0.5-4.fc29                             @rpmfusion-free           
vo-amrwbenc.x86_64                               0.1.3-8.fc29                             @rpmfusion-free           
x264-libs.x86_64                                 0.155-2.20180806git0a84d98.fc29          @rpmfusion-free-updates   
x265-libs.x86_64                                 2.8-1.fc29                               @rpmfusion-free           
xvidcore.x86_64                                  1.3.5-3.fc29                             @rpmfusion-free   







@ I am checking your advices provided at 2018-12-19 09:19:02 UTC...
I do not see timeout in the log... - I am not sure if it is the same....

Comment 4 tothaa 2018-12-20 00:09:02 UTC
Created attachment 1515778 [details]
log when failure with new kernel

Comment 5 tothaa 2018-12-20 00:09:33 UTC
Created attachment 1515779 [details]
log when good with old kernel

Comment 6 Steve 2018-12-20 06:38:33 UTC
> But I found "amdgpu 0000:01:00.0: Fatal error during GPU init" in the log :S

Thanks for pointing that out. This could be the problem:

dec 20 01:19:57 localhost.localdomain kernel: mc: Failed to load firmware "amdgpu/polaris11_k_mc.bin"

See: Bug 1520682 - amdgpu module fails to load firmware 

The firmware should be here:

$ rpm -ql linux-firmware | grep polaris11

The "lsinitrd" command will show what is in the initramfs:

# lsinitrd -k 4.20.0-0.rc7.git0.1.vanilla.knurd.1.fc29.x86_64 | grep polaris11

Comment 7 Steve 2018-12-20 07:29:47 UTC
Try updating linux-firmware from here:

Information for build linux-firmware-20181219-89.git0f22c852.fc29
https://koji.fedoraproject.org/koji/buildinfo?buildID=1174570

Specifically:

# dnf update https://kojipkgs.fedoraproject.org//packages/linux-firmware/20181219/89.git0f22c852.fc29/noarch/linux-firmware-20181219-89.git0f22c852.fc29.noarch.rpm

Tested in an F29 VM:

$ rpm -q linux-firmware
linux-firmware-20181219-89.git0f22c852.fc29.noarch

$ rpm -ql linux-firmware | grep polaris11_k_mc.bin
/usr/lib/firmware/amdgpu/polaris11_k_mc.bin

Note that the package is not signed, because it hasn't been released:

$ rpm -qi linux-firmware | grep Signature
Signature   : (none)

Comment 8 Steve 2018-12-20 07:55:39 UTC
It seems this bug was reported 2018-12-16 17:21 UTC:

Bug 1659810 - linux-firmware: amdgpu fatal error during gpu init 

(In reply to Steve from comment #7)
> Try updating linux-firmware from here:
...

Anyway, I actually started here:

Fedora Packages Search
https://apps.fedoraproject.org/packages/

Although I could have started here:

Fedora Updates System
https://bodhi.fedoraproject.org/

See, also:

Fedora Project Packages GIT repositories
https://src.fedoraproject.org/cgit/

I recommend bookmarking all of those ...

Comment 9 Steve 2018-12-21 03:37:11 UTC
According to a comment on Bodhi, the initramfs needs to be rebuilt:

bugfix update in Fedora 29 for linux-firmware
https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

There aren't any examples in the comment, but try something like this:

# dracut --kver 4.20.0-0.rc7.git0.1.vanilla.knurd.1.fc29.x86_64 --force

Documentation:

$ man dracut

Comment 10 tothaa 2018-12-21 06:58:47 UTC
Hi All,
Thank you for your answer!

I updated linux-firmware as Steve suggested, but it did not make any difference.

I also updated my system and it installed kernel 4.20.0-0.rc7.git1.1.vanilla.knurd.1.fc29.x86_64. - with this, it loads fine again :-).

Yours,
 András

Comment 11 tothaa 2018-12-21 07:01:16 UTC
With the dracut tool on the 4.20.0-0.rc7.git0.1.vanilla.knurd.1.fc29.x86_64 version; it is now also working fine. Thank you!

Comment 12 Steve 2018-12-21 13:00:32 UTC
Thanks for your reports. If you feel like it, you could post karma here:

bugfix update in Fedora 29 for linux-firmware
https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

Comment 13 Jeremy Cline 2019-01-07 20:03:23 UTC

*** This bug has been marked as a duplicate of bug 1659810 ***


Note You need to log in before you can comment on or make changes to this bug.