Bug 1659810 - linux-firmware: amdgpu fatal error during gpu init
Summary: linux-firmware: amdgpu fatal error during gpu init
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware   
(Show other bugs)
Version: 29
Hardware: Unspecified Unspecified
urgent
urgent
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1660507 1660674 1660772 1660776 1661681 (view as bug list)
Depends On:
Blocks: 1661024
TreeView+ depends on / blocked
 
Reported: 2018-12-16 17:21 UTC by Carl George
Modified: 2019-01-07 20:06 UTC (History)
35 users (show)

Fixed In Version: linux-firmware-20181219-89.git0f22c852.fc29 linux-firmware-20181219-89.git0f22c852.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-12-23 02:52:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carl George 2018-12-16 17:21:16 UTC
Description of problem:
With the latest kernel from updates testing (4.19.9-300), my computer boots but the screen stays black (no visible gdm).  When I ssh in from another machine, gdm says it's running.  In the journal I found this error message:

    Dec 16 11:12:36 zeratul kernel: amdgpu 0000:01:00.0: Direct firmware load for amdgpu/polaris11_k_mc.bin failed with error -2
    Dec 16 11:12:36 zeratul kernel: mc: Failed to load firmware "amdgpu/polaris11_k_mc.bin"
    Dec 16 11:12:36 zeratul kernel: [drm:gmc_v8_0_sw_init [amdgpu]] *ERROR* Failed to load mc firmware!
    Dec 16 11:12:36 zeratul kernel: [drm:amdgpu_device_init.cold.28 [amdgpu]] *ERROR* sw_init of IP block <gmc_v8_0> failed -2
    Dec 16 11:12:36 zeratul kernel: amdgpu 0000:01:00.0: amdgpu_device_ip_init failed
    Dec 16 11:12:36 zeratul kernel: amdgpu 0000:01:00.0: Fatal error during GPU init
    Dec 16 11:12:36 zeratul kernel: [drm] amdgpu: finishing device.
    Dec 16 11:12:36 zeratul kernel: amdgpu: probe of 0000:01:00.0 failed with error -2

The previous 4.19.8-300 kernel did not have this issue.  The hardware is a custom PC with an ASUS H87I-PLUS motherboard and an ASUS Radeon RX 560 graphics card.

Version-Release number of selected component (if applicable):
kernel-4.19.9-300.fc29.x86_64

How reproducible:
always

Steps to Reproduce:
1. boot into 4.19.9-300 kernel

Actual results:
Black screen and aforementioned errors in the journal.

Expected results:
Normal boot with gdm showing so I can log in and use my computer.

Comment 1 Yanko Kaneti 2018-12-17 14:33:32 UTC
linux-firmware in Fedora is lagging behind upstream. It looks like the gpu firmware in question was added upstream on Dec 3

Comment 2 Jeremy Cline 2018-12-17 14:45:52 UTC
Indeed. The file in question is https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/amdgpu/polaris11_k_mc.bin. You can drop that in /lib/firmware/amdgpu/ and then regenerate your initramfs with dracut which should work until there's an update for the firmware package.

Comment 3 Yanko Kaneti 2018-12-18 13:41:26 UTC
*** Bug 1660507 has been marked as a duplicate of this bug. ***

Comment 4 Yanko Kaneti 2018-12-19 17:45:35 UTC
*** Bug 1660776 has been marked as a duplicate of this bug. ***

Comment 5 Yanko Kaneti 2018-12-19 17:50:04 UTC
*** Bug 1660674 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2018-12-20 05:06:15 UTC
linux-firmware-20181219-89.git0f22c852.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

Comment 7 Fedora Update System 2018-12-20 05:06:24 UTC
linux-firmware-20181219-89.git0f22c852.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7d88c302b7

Comment 8 Fedora Update System 2018-12-21 05:47:02 UTC
linux-firmware-20181219-89.git0f22c852.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7d88c302b7

Comment 9 Lukas Zapletal 2018-12-21 15:27:02 UTC
For googlers:

dnf upgrade https://kojipkgs.fedoraproject.org//packages/linux-firmware/20181219/89.git0f22c852.fc29/noarch/linux-firmware-20181219-89.git0f22c852.fc29.noarch.rpm
dracut -fv /boot/initramfs-4.19.9-300.fc29.x86_64.img 4.19.9-300.fc29.x86_64
reboot

Comment 10 Fedora Update System 2018-12-21 21:05:53 UTC
linux-firmware-20181219-89.git0f22c852.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

Comment 11 Fedora Update System 2018-12-23 02:52:54 UTC
linux-firmware-20181219-89.git0f22c852.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Wade Berrier 2018-12-24 05:36:39 UTC
Thanks for the fix.

Just wanted to point out that even though I had the correct linux-firmware package, I still needed to update my initramfs manually ("dracut --regenerate-all --force").

Comment 13 Carl George 2018-12-26 20:59:42 UTC
I'm late to the party, but this does fix the issue for me.  Thanks!

Comment 14 Fedora Update System 2018-12-30 01:39:10 UTC
linux-firmware-20181219-89.git0f22c852.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Jeremy Cline 2019-01-07 20:03:23 UTC
*** Bug 1660772 has been marked as a duplicate of this bug. ***

Comment 16 Jeremy Cline 2019-01-07 20:06:23 UTC
*** Bug 1661681 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.