Bug 1661146 - oc add taint to node fail
Summary: oc add taint to node fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.1.0
Assignee: Vikas Choudhary
QA Contact: MinLi
URL:
Whiteboard:
: 1661148 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-20 07:46 UTC by MinLi
Modified: 2019-06-04 10:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:32 UTC

Description MinLi 2018-12-20 07:46:28 UTC
Description of problem:
oc add taint to node fail

Version-Release number of selected component (if applicable):
oc v4.0.0-alpha.0+1cdd4a1-781
kubernetes v1.11.0+1cdd4a1
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://zzhao-api.devcluster.openshift.com:6443
kubernetes v1.11.0+1cdd4a1


How reproducible:
always

Steps to Reproduce:
1.add taint to node
#oc adm taint node ip-10-0-148-66.ec2.internal role=master:NoSchedule
node/ip-10-0-148-66.ec2.internal tainted
2.check node for taint info
#oc describe node ip-10-0-148-66.ec2.internal | grep -i taint
Taints: <none>
3.remove taint from node
#oc adm taint node ip-10-0-148-66.ec2.internal role:NoSchedule-
error: taint "role:NoSchedule" not found

Actual results:
1.add taint to node succ
2.the node has no taint
3.can not found taint

Expected results:
2.the node show taint correctly
3.remove taint succ


Additional info:

Comment 1 Seth Jennings 2018-12-20 15:01:57 UTC
*** Bug 1661148 has been marked as a duplicate of this bug. ***

Comment 2 Seth Jennings 2018-12-20 19:04:33 UTC
The machine-api-controller is currently stomping taints on nodes.

There is a PR to remedy this:
https://github.com/openshift/machine-api-operator/pull/154

Sending to Cloud.

Comment 3 MinLi 2018-12-25 07:04:36 UTC
Feature of Scheduling relevant to Taints and Tolerations is all blocked by this bug.
Taints and tolerations allow the node to control which pods should (or should not) be scheduled on them.

attach trello list for reference:
[tolerations] Toleration key related changes [Alpha-to-Beta] https://trello.com/c/CWN4JmQM
[tolerations] Move taints and tolerations from beta to v1 [Beta to v1] https://trello.com/c/fiXcWhVz

Comment 4 W. Trevor King 2019-01-14 14:09:51 UTC
Can this be marked fixed?  The referenced PR landed 11 days ago [1].

[1]: https://github.com/openshift/machine-api-operator/pull/154#event-2051873056

Comment 5 MinLi 2019-01-15 09:17:26 UTC
fixed!
This bug Status is always "NEW" since created, which make me think the bug has not fixed. Pls set the Status to "MODIFIED" timely when fixed, thx @W. Trevor King

version info:
oc v4.0.0-0.125.0
kubernetes v1.11.0+406fc897d8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-jialiu-api.qe.devcluster.openshift.com:6443
kubernetes v1.11.0+c69f926354

Comment 8 errata-xmlrpc 2019-06-04 10:41:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.