Bug 1661148 - kubelet add taint to node fail
Summary: kubelet add taint to node fail
Keywords:
Status: CLOSED DUPLICATE of bug 1661146
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Seth Jennings
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-20 07:53 UTC by MinLi
Modified: 2019-03-12 14:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-20 15:01:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description MinLi 2018-12-20 07:53:56 UTC
Description of problem:
kubelet add taint to node fail. Though api-server prompt add taint succ, indeed add fail.

Version-Release number of selected component (if applicable):
kubectl version:
Client Version: version.Info{Major:"1", Minor:"11+", GitVersion:"v1.11.0+1cdd4a1", GitCommit:"1cdd4a1", GitTreeState:"clean", BuildDate:"2018-12-17T12:20:26Z", GoVersion:"go1.10.3", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"11+", GitVersion:"v1.11.0+1cdd4a1", GitCommit:"1cdd4a1", GitTreeState:"clean", BuildDate:"2018-12-17T12:16:52Z", GoVersion:"go1.10.3", Compiler:"gc", Platform:"linux/amd64"}


How reproducible:
always

Steps to Reproduce:
1.add taint to node
#kubectl taint node ip-10-0-148-66.ec2.internal role=master:NoSchedule
node/ip-10-0-148-66.ec2.internal tainted
2.check node for taint info
#kubectl describe node ip-10-0-148-66.ec2.internal | grep -i taint
Taints: <none>
3.remove taint from node
# kubectl taint node ip-10-0-148-66.ec2.internal role:NoSchedule-
error: taint "role:NoSchedule" not found

Actual results:
1.add taint to node succ
2.the node has no taint
3.can not found taint

Expected results:
2.the node show taint correctly
3.remove taint succ

Additional info:

Comment 1 Seth Jennings 2018-12-20 15:01:57 UTC

*** This bug has been marked as a duplicate of bug 1661146 ***


Note You need to log in before you can comment on or make changes to this bug.