Bug 1661275 - Fail to boot with kernel >=4.19.9
Summary: Fail to boot with kernel >=4.19.9
Keywords:
Status: CLOSED DUPLICATE of bug 1661024
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-20 16:45 UTC by Chris Irwin
Modified: 2018-12-23 11:47 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-20 17:32:52 UTC


Attachments (Terms of Use)
fpaste --sysinfo output (19.33 KB, text/plain)
2018-12-20 16:45 UTC, Chris Irwin
no flags Details
Failed boot with 4.19.10-300 (9.84 MB, image/jpeg)
2018-12-20 16:48 UTC, Chris Irwin
no flags Details
Sucessful boot with 4.19.8-300 (8.85 MB, image/jpeg)
2018-12-20 16:49 UTC, Chris Irwin
no flags Details

Description Chris Irwin 2018-12-20 16:45:40 UTC
Created attachment 1515923 [details]
fpaste --sysinfo output

Description of problem:

Fresh install of Fedora 29 on a new Ryzen machine w/ RX550 GPU (AMDGPU-supported). Boots correctly with 4.18.16 kernel (installed with system) through to 4.18.8. However, 4.19.9 and 4.19.10 (currently in updates-testing) both fail to boot (before the opportunity to enter my LUKS passphrase).

Version-Release number of selected component (if applicable):

4.19.9-300.fc29

How reproducible:

100%, every boot

Steps to Reproduce:
1. Update to kernel-4.19.9-300.fc29
2. Reboot
3. Boot with kernel-4.19.9-300.fc29

Actual results:

Blank screen, fans didn't spin up

Expected results:

Passphrase prompt via plymouth, fans spin up.


Additional info:

Attached is output from `fpaste --sysinfo`

I've additionally booted both 4.19.8 (working) and 4.19.9 (broken) without "rhgb quiet" on the command line, then taken photos.

4.19.9 (broken) hangs when switching the framebuffer to amdgpudrmfb. (screenshot added in additional comment to follow)

4.19.8 (working) blanks the screen and prints a bunch of drm info (it waits here for me to type my passphrase, although the prompt was lost during the screen blank) (screenshot added in additional comment to follow)

Comment 1 Chris Irwin 2018-12-20 16:48:06 UTC
Created attachment 1515924 [details]
Failed boot with 4.19.10-300

Attaching screenshot of failed boot with `rhgb quiet` removed from the kernel command line

Comment 2 Chris Irwin 2018-12-20 16:49:42 UTC
Created attachment 1515925 [details]
Sucessful boot with 4.19.8-300

Attaching screenshot of successful boot with `rhgb quiet` removed from the kernel command line

(It waits here for me to type my LUKS passphrase, although the prompt was lost during the amdgpudrmfb screen blank)

Comment 3 Chris Irwin 2018-12-20 17:25:45 UTC
As per the 4.19.9 changelog[1], there were a few changes to amdgpu, namely:

* drm/amdgpu/gmc8: always load MC firmware in the driver

and 

* drm/amdgpu/gmc8: update MC firmware for polaris

The timestamp on that latter commit was "Wed Nov 28 23:25:41 2018 -0500", however the current linux-firmware package is dated "20181008-88.gitc6b6265d", which predates the updated firmware.

Manually fetching linux-firmware-20181219-89.git0f22c852.fc29 from koji, installing it, and rebuilding the initrd (`dracut --kver=4.19.10-300.fc29.x86_64 --force`) results in a properly working system.

This appears to be a bug due to the kernel needing an updated linux-firmware, but none was available.


Kernel Changelog: https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.9

Comment 4 Chris Irwin 2018-12-20 17:32:52 UTC

*** This bug has been marked as a duplicate of bug 1661024 ***


Note You need to log in before you can comment on or make changes to this bug.