Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1661024 - 4.19.8-300.fc29.x86_64 -> 4.19.9-300.fc29.x86_64 update results in black screen (missing GPU firmware)
Summary: 4.19.8-300.fc29.x86_64 -> 4.19.9-300.fc29.x86_64 update results in black scre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1661275 (view as bug list)
Depends On: 1659810
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-19 21:19 UTC by Török Edwin
Modified: 2019-01-01 04:07 UTC (History)
23 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-23 02:52:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Török Edwin 2018-12-19 21:19:57 UTC
Description of problem:
Black screen, no GPU output after upgrading the kernel

Version-Release number of selected component (if applicable):
kernel 4.19.9-300.fc29.x86_64 is buggy it tries to read a firmware file which does not exist.

How reproducible:
Boot system with 4.19.8-300, all good, boot system with upgraded kernel 4.19.9 - black screen, I can only SSH in, no text terminal either.


Steps to Reproduce:
1. This can be reproduced on Fedora Silverblue with rpm-ostree quite easily https://pagure.io/teamsilverblue/issue/63
2. Boot deployment commit 377ba4c80d3f1db706358dfdee84e0c0156d96f07ef6311d237268f52a6f130e works
3. rpm-ostree upgrade, and reboot results in newer kernel and black screen

Actual results:
Failed to load GPU firmware

Expected results:
Working GPU


Additional info:
Dec 19 19:56:06 localhost kernel: amdgpu 0000:01:00.0: Direct firmware load for amdgpu/polaris11_k_mc.bin failed with error -2
Dec 19 20:31:25 localhost kernel: amdgpu 0000:01:00.0: Direct firmware load for amdgpu/polaris11_k_mc.bin failed with error -2
Dec 19 20:46:09 localhost kernel: amdgpu 0000:01:00.0: Direct firmware load for amdgpu/polaris11_k_mc.bin failed with error -2
Dec 19 20:54:48 localhost kernel: amdgpu 0000:01:00.0: Direct firmware load for amdgpu/polaris11_k_mc.bin failed with error -2

linux-firmware bug here:
https://bugzilla.redhat.com/show_bug.cgi?id=1659810
The kernel package needs to add a >= dependency on the new linux-firmware package, the new version of kernel shouldn't have been pushed to stable while it was missing firmware files.

See here, there is another user reporting same problem, and the kernel was pushed to stable even though this problem was known!
https://bodhi.fedoraproject.org/updates/FEDORA-2018-2645eb8dab
Please check karma feedback on the package before pushing updates to stable!

Comment 1 Török Edwin 2018-12-19 21:28:59 UTC
I've opened a Bodhi issue as well, there was negative karma saying the kernel is unusable before the push to stable, perhaps the settings are not strict enough?
https://github.com/fedora-infra/bodhi/issues/2874

Comment 2 Laura Abbott 2018-12-19 22:01:42 UTC
This isn't a bodhi issue. We push kernel updates manually. There are so many hardware combinations out there we often have to make our best judgement about when to push an update even if it may not work on all combinations. It does look like we've increased the firmware requirement in the past so we can see about adding that when the firmware package gets built.

Comment 3 Peter Robinson 2018-12-20 04:41:38 UTC
It's also really hard to do a kernel <-> firmware dependency, ultimately why did it work with 4.18 and not with 4.19 when the firmware was missing? That could be argued it's a kernel regression because it should fail gracefully, but I ultimately aren't sure that's something a distro can get 100% right because as Laura said there's a lot of HW <-> kernel <-> firmware combos.

Comment 4 Fedora Update System 2018-12-20 05:06:13 UTC
linux-firmware-20181219-89.git0f22c852.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

Comment 5 Fedora Update System 2018-12-20 05:06:22 UTC
linux-firmware-20181219-89.git0f22c852.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7d88c302b7

Comment 6 Chris Irwin 2018-12-20 17:32:52 UTC
*** Bug 1661275 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2018-12-21 05:47:01 UTC
linux-firmware-20181219-89.git0f22c852.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7d88c302b7

Comment 8 Steve 2018-12-21 19:33:44 UTC
Assuming I am looking at the right upstream git repo, a good place to start fixing the linux firmware release process would be to use git tags. There are no tags here:

https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/refs/

Comment 9 Fedora Update System 2018-12-21 21:05:52 UTC
linux-firmware-20181219-89.git0f22c852.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

Comment 10 Fedora Update System 2018-12-23 02:52:52 UTC
linux-firmware-20181219-89.git0f22c852.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Steve 2018-12-23 18:13:03 UTC
(In reply to Török Edwin from comment #1)
> I've opened a Bodhi issue as well, there was negative karma saying the
> kernel is unusable before the push to stable, perhaps the settings are not
> strict enough?
> https://github.com/fedora-infra/bodhi/issues/2874

There is another Bodhi issue -- the summary column only shows *net* karma.

With over 20 comments it would be easy to overlook a few negative comments. Bodhi should show negative karma *separately* in the summary column.

security update in Fedora 29 for kernel and kernel-headers 
https://bodhi.fedoraproject.org/updates/FEDORA-2018-2645eb8dab

Comment 12 Peter Robinson 2018-12-24 00:54:21 UTC
> There is another Bodhi issue -- the summary column only shows *net* karma.
> 
> With over 20 comments it would be easy to overlook a few negative comments.
> Bodhi should show negative karma *separately* in the summary column.
> 
> security update in Fedora 29 for kernel and kernel-headers 
> https://bodhi.fedoraproject.org/updates/FEDORA-2018-2645eb8dab

This is not the place to comment on bodhi bugs, it'll get lost in the kernel bug, please report it: https://github.com/fedora-infra/bodhi/issues/

Comment 13 Fedora Update System 2018-12-30 01:39:08 UTC
linux-firmware-20181219-89.git0f22c852.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.