Bug 166138 - Unexpected characters are inserted by 3bul Yetgeul
Unexpected characters are inserted by 3bul Yetgeul
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scim-hangul (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
: 166126 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-08-17 06:00 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 0.2.0-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-04 21:12:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2005-08-17 06:00:52 EDT
+++ This bug was initially created as a clone of Bug #166126 +++

If you accidentally enable scim-hangul's "3bul Yetgeul" then dismiss it with
CTRL-SPACE, the TAB key behaves strangely.  ALT-TAB window switching works, but
every time I switch between apps it inserts this "ᅟᅠ" (between the quotes)
blank character into the text area.  Within xchat TAB inserts those invisible
multibyte characters rather than behave how you expect.

Key behavior is not supposed to be different when the IM is disabled and the
language bar is not visible.

This is also part of the bigger question, what exactly are these 3bul Input
Method?  Are they important for FC5/RHEL5?

If they are important, can we integrate them in some way to reduce their
quantity and intrusiveness?
Comment 1 Akira TAGOH 2005-08-17 06:04:12 EDT
David, I'd ask you about this behavior on the 3bul input style. is inserting an
above character with Tab, expected behavior on 3bul input style? or should only
Tab(0x09) inserted by Tab key?
Comment 2 David Joo 2005-08-17 18:36:33 EDT
http://go-dent.com/images/new/3kf_mac.gif

According to the above website, TAB should be the TAB.

Regards,
David Joo
Comment 3 David Joo 2005-08-17 18:40:22 EDT
Tagoh-san,

3bul style is a style of korean keymap on normal qwerty keyboard.
If you are seeing those errors I would think that it is more towards on
"pre-editing" affecting all the apps. Meaning, when the tab was pressed, it will
be stored in pre-edit area, not being committed to an application, and causing
that behaviour.

I hope, I am making sense.

Regards,
David Joo
Comment 4 Warren Togami 2005-08-19 08:20:02 EDT
*** Bug 166126 has been marked as a duplicate of this bug. ***
Comment 5 Warren Togami 2005-08-19 08:25:30 EDT
Sorry, Tagoh misunderstood what I tried to describe in IRC.  The identity and
function of the IM engine are irrelevant to the bug of this report.

The key problem in this bug is that 3bul Yetgeul is inserting unexpected
characters into applications when it should be disabled.  None of the other IM
methods do this when the language bar is dismissed.

Similar misbehavior can be observed by using CTRL-SHIFT to cycle through the
available IM engines.  When you cycle past 3bul Yetgeul, it inserts two
unexpected characters into the current application.

I will address the further questions of 2bul vs. 3bul later.
Comment 6 Akira TAGOH 2005-08-25 02:25:37 EDT
The problem is that scim-hangul is going to insert Hangul Choseong/Jungseong
Filler by pressing those keys, which shouldn't be.
Comment 7 Akira TAGOH 2005-08-26 04:47:03 EDT
this should be fixed in 0.2.0-5.fc5. please confirm.

Note You need to log in before you can comment on or make changes to this bug.